1

[Moved from Data Science Stack Exchange to here, 10/17/2019]

I have seen something like this question asked 4 times before. But no one has provided an answer, so far. See:

[Screenshot showing Jupyter Notebook launched from an Anaconda command prompt, and resulting web page opened in Chrome]

Screenshot showing Jupyter Notebook launched from an Anaconda command prompt, and resulting web page opened in Chrome

I'm running Anaconda 3 on a Windows 7 PC. I have been using Jupyter Notebooks for nearly a year on this machine. One day, a couple of weeks back, I could no longer do anything useful with Jupyter Notebooks. I can launch Jupyter from an Anaconda prompt or by clicking on the link in my Start Menu (under Anaconda3) or by lauching Anaconda Navigator and clicking from there. In all cases, everything looks OK except that I get stuck at the root of my notebook tree and I can't get to, or otherwise open an iPython notebook. I've tried using Chrome, Firefox, and (pwah!) Internet Explorer browsers and get the same result.

I've tried editing the Jupyter configuration file in my C:\Users\myname\.jupyter directory. I can tell from the text emitted when I start that Jupyter is picking up the info in that file, because I can change it and it changes the text output.

I tried uninstalling everything, Anaconda and even Python. Rebooting, and then re-installing Anaconda3. I was pretty disappointed when this didn't work. I have a feeling that there is an easy fix to this, but it is beyond me. To show an example, I'm attaching a screenshot of an Anaconda command window and how the browser looks when Notebook starts. I can, of course, type "file:///blah" into the address bar and I definitely get a view of the directory. But this breaks the Jupyter Notebook activity, so clicking on an *ipynb file just opens it in a text editor with all the JSON curly brackets and so forth. Not much use.

BTW, I have no trouble launching Spyder.

How can I navigate to, and open, an IPython notebook in Jupyter? Thanks.

1

It is a bug in the latest update to jupyter notebooks. The workaround is to downgrade back to the most recent working copy. I really wanted a way that used conda and not pip to downgrade, and I found an excellent solution. Anaconda keeps an archive of previous releases of the entire system (conda + jupyter + spyder + ...). You can find the archive here:

https://repo.continuum.io/archive/

For me, the version that worked was the July 2019 release

https://repo.continuum.io/archive/Anaconda3-2019.07-Windows-x86_64.exe

First you must uninstall Anaconda completely and then install the archived version.

0

This may help: Downgrade it to a different version.

pip uninstall notebook
pip install notebook==5.7.4

Source

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.