3

I have a series of dates in a column, currently recognized as text. Thus sorting doesn't work correctly.

enter image description here

When highlighting the column and changing the format to Date, Excel still recognizes it as text (you can notice it: it stays left-aligned).

The only solution I've found is to go on each cell individually and hit F2 and then ENTER.

If there are many cells, going to the top and hitting F2, ENTER, F2, ENTER.... is not really an option.

What faster solution is there?

Doing a multiplication by 1 seems to work but is there a nicer way?

  • 3
    Text to Columns, do not split on anything. – Scott Craner Oct 18 '19 at 13:39
  • @ScottCraner I think you can post it as an answer! – Basj Oct 18 '19 at 13:56
0

As mentioned by Scott in a comment, selecting one single column and using the feature Text to columns (with no splitting at all) solves the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.