0

I'm running Apache2 on Ubuntu Server in a virtual machine on my host computer. The network attached to setting in Oracle Virtual Box is set to bridged.

I can see the test website on my local machine and local network. However, not from outside of my local network, which is what I'd like.

Apache2 is serving on port 80. I have also forwarded port 80 to the IP Address of the virtual machine. 192.xxx.x.xx (Virgin Media Router).

The ufw firewall on Ubuntu is set to allow Apache2 through.

Really not sure what I'm doing wrong, or missing here. I'm somewhat new at this so help would be appreciated! I've read through hundreds of posts on here and can't find an answer. :(

0

If you router is a home modem/router it is by default not letting external connections in. You have to tell it to forward the port 80 to your local machine which will in turn forward it to your VM.

Note that running a server from your home isn't a very good idea, if you overlook something you can put all the machines in your household in jeopardy. Best use a server in the cloud. Virtual servers are quite cheap (mine: 1x2.40Ghz Xeon code, 1GB RAM, 25H disk: $5 a month).

| improve this answer | |
  • Thanks for the rapid response. Yes, absolutely not a good idea, it's only temporary while I test a couple of things, and will be turned off while not in use. I've just tried directing the port forward to the host machine's IP instead of the VMs. Still no joy. I must have overlooked something somewhere. – Paul Freeman Oct 20 '19 at 0:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.