I have a Toshiba Satellite C850 19Q with Windows 10x64 Home, today I noticed that my laptop does no more have option to connect to wifi, however before everything was fine, now i can only use ethernet, i tried all solutions i found - reseting with command line, reseting from settings and updated drivers, nothing helped me, and I also need to say that I cannot enter bios, because the boot screen does not tell me how to. please help!

Edit I have installed new wifi card and it still doesnt work

  • 1
    Have you opened your laptop and made sure that the antenna is properly connected to the wifi card? – Mokubai Oct 20 '19 at 11:23
  • i never opened my laptop, but the system should show wifi options even without antenna or not? – LilArtyXd Oct 20 '19 at 11:24
  • however i dont even know which one is antenna and which one is wifi-card – LilArtyXd Oct 20 '19 at 11:29
  • I missed that in your question, but it could be that the wifi card has died or worked loose. – Mokubai Oct 20 '19 at 11:32
  • but... in device manager i can see it – LilArtyXd Oct 20 '19 at 11:42

Laptops of this type have a hardware wifi on/off switch. It will be activated by holding down the function key (bottom left) and pressing one of the top line of keys on the keyboard. Look for one that may resemble an aerial or wifi related then whilst holding down function press that key. Your wifi should re-enable.

  • Well, mine doesnt have the wifi switch – LilArtyXd Oct 20 '19 at 15:54
  • @LilArtyXd smallbusiness.chron.com/… – user931000 Oct 20 '19 at 18:29
  • @LilArtyXd askubuntu.com/a/106791 – user931000 Oct 20 '19 at 18:32
  • 2
    Every Toshiba laptop has the wireless switch. Help us to help you and look for it. – JohnnyVegas Oct 20 '19 at 18:49
  • 2
    Another possibility is airplane mode. – JohnnyVegas Oct 20 '19 at 18:50

On my Toshiba you have to press "FN" (Blue color) simultaneously with "F8" (that has a wireless network signal also in blue color).

  • It shows me the video/audio play/pause, next and previous buttons hud – LilArtyXd Oct 20 '19 at 16:14
  • On your keyboard it's only "F12". P.S. - The previous option was "Network troubleshooter" . – Miguel Ângelo Rodrigues Oct 20 '19 at 16:16
  • seems like it does not have any effect – LilArtyXd Oct 20 '19 at 16:20
  • Are you in AirPlane Mode? If not: Go to:<br> Control Painel. (Search for it on Windows)<br> Network & Internet.<br> Network troubleshooter.<br> If not solved press F12 key the repeat all. – Miguel Ângelo Rodrigues Oct 20 '19 at 16:24
  • I cant see Network Troubleshooter – LilArtyXd Oct 20 '19 at 16:26

If the issue is that you are not seeing the wifi list at all then this should help.

I have come across this issue since Windows 10 did some updates but I cannot tell which one (seems like one of the cumulative updates).

  • Run Services as administrator.
  • Double click on Wireless Connection Manager service.
  • Goto Logon tab, change the "Log on as" to Local System account. Click on Apply.
  • Goto General Tab, start the service and click OK.
  • Goto WLAN AutoConfig and start the service as well. Now you should be able to see the Wifi list and connect to them.

Hope this helps.

  • Little problem.. upload.hicoria.com/files/yc2tx8Ah.jpg I cant find it (I dont have updates downloaded) – LilArtyXd Nov 2 '19 at 19:16
  • I see the WLAN Autoconfig in the picture, you dont see the Wireless Connections Manager in the list? if you scroll up you should be able to see it. – Sid_Hussey Nov 5 '19 at 21:33
  • No it isnt there – LilArtyXd Nov 5 '19 at 22:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.