13

According to powercfg –lastwake my computer woke up from sleep for the following reason:

Wake History Count - 1
Wake History [0]
  Wake Source Count - 1
  Wake Source [0]
    Type: Wake Timer
    Owner: [PROCESS] \Device\HarddiskVolume4\Program Files\Oracle\VirtualBox\VBoxSVC.exe

According to https://windowsreport.com/windows-8-windows-10-wakes-sleep-fix/, if I click on the Power Management tab I can uncheck "Allow this device to wake the computer" to prevent the device from waking my computer up again.

Only problem: I don't have that tab!:

Enter image description here

Some of my network adapters have it (my physical network adapters), but not the one that woke my computer up.

Any ideas?

  • That adapter is usually present in a virtual machine only. – GabrielaGarcia Oct 20 at 19:52
  • I'm not sure if that option exists for VM virtual adapters... however, I have seen physical adapters in Windows missing config options until the adapter's manufacturer's drivers are installed from that manufacturer's site. – JW0914 Oct 20 at 20:00
  • @GabrielaGarcia No, this is the adapter in the host. – Lightness Races with Monica Oct 21 at 14:19
15

This is a known VirtualBox bug: Ticket #18549 : Windows host wakes from standby mode constantly.

The bug was marked as fixed about 5 months ago, so should be included in the latest version VirtualBox 6.0.14, released October 15 2019. (Actually it should have already been in some release even sooner than that.)

I suggest refreshing your VirtualBox version. If the problem is not fixed, you could ask to re-open that bug-report, and use Albin's solution in the meantime (although it might be a bit too strong).

7

It doesn't look like the (any) network card is waking your computer but the Wake Timer in Windows 10. You can disable them globally, see here and here.

For example open power options and choose "disable":

enter image description here

But I'm not sure how this connects to VBoxSVC.exe. However I would try to disable them and see if this resolves the issue first.

  • It looks like wake timers are already disabled on battery for my laptop. Doesn't look like that setting was preventing my laptop from waking up anyway. Maybe the issue was the sequence in which I was doing things. I would shut it down while it was plugged in and then a few minutes later unplug it and put it in my backpack. Maybe I should have been unplugging it first and then shutting it down after it had been unplugged... – neubert Oct 21 at 12:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.