0

I have an Amazon EC2 instance that I have been using to learn networking concepts on, today I tried to connect via SSH and was prompted with the following error.

@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@         WARNING: UNPROTECTED PRIVATE KEY FILE!          @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
Permissions for 'C:\Users\Ryan\aws-ec2-server.pem' are too open.
It is required that your private key files are NOT accessible by others.
This private key will be ignored.

I tried looking into the issue, following the replies given to this thread. Unfortunately once I changed the permissions of the file, I was receiving the same error. Many of the other replies give guidance on how to correct this error using chmod, but unfortunately I'm running on windows and have not been able to find an adequate solution that works for me.

0

On Windows I find it easiest to use putty rather than the command line ssh client.

You need to convert your pem file to ppk. Run "puttygen" on your computer, point it at the saved pem private key, then save the ppk private key. Then set up putty with the user@ip and private key. There will be tutorials around if you need more help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.