1

I installed on a fresh Windows10 Anaconda to use the Jupyter Notebook.
But it will not work with this error:

Traceback (most recent call last):
.....
File "C:\Users\Kolja\AppData\Roaming\Python\Python37\site-packages\jupyter_core\paths.py", line 359, in win32_restrict_file_to_user import win32api
ImportError: DLL load failed: The specified procedure could not be found.

I installed the win32 manually, but I think they will be there before.
I uninstalled anaconda, cleaned the registry, and tried again - same error.

What can I do?

0
0

Does (say) Spyder work and only Jupyter Notebooks aren't working, or does Spyder also have the same error? Did you add the location of your python interpreter to the PATH variable? When Anaconda is installed on Linux it prompts whether you'd like to do this automatically, but I don't remember if Windows does the same thing. I seem to remember having to manually add the path.

If you did indeed do this already, check out this answer regarding adding the DLL location to our environment variables path.

1
  • Yes, Spider have the same error, Anaconda add the python interpreter into PATH during the installation and i add (after your answer) the DLLs location to PATH, nothing changes. The last time ( a year ago) everything workst out of the box. – kolja Oct 22 '19 at 6:30
0

Same error, both in Jupyter and Spyder. I already tried to add the location of your python interpreter to the PATH variable, and still not working. I uninstalled, deleted everything remaining, cleaned the registry, installed from scratch again and again, trying diferent options, and nothing.

Then I now removed the Python folder from the "C:\Users[MY USERNAME]\AppData\Roaming" folder, and then reinstalled Anaconda 64 bits again, and now it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.