1

I hope this is a simple issue for someone to just point me at the right setting, but i'm having issues getting sharing working between PCs on my network. The issue is if any clients try and connect to my server, they're prompted for a username and password despite password-protected sharing being off, and even if i put in the server's username and password, won't allow the clients to connect.

  • The Server (called "Ravnica") runs Win 10 Home 1903, is a desktop tower connected via Ethernet.
  • The primary Client (called "Innistrad") runs Win 10 Home 1809, is a laptop and can be connected by either Wireless or Ethernet depending on location
  • The secondary Client (called "Ixalan") runs Win 10 Home 1903, is a desktop tower connected via Ethernet.

The issue is if either Innistrad or Ixalan try and connect to Ravnica, they're prompted for a username and password, which is both undesirable (as Ixalan is my housemate's PC) and even if Ravnica's admin username and password are put in, it'll not allow access. This is despite all PCs having all of the following set:

  • Private network
  • Network discovery on
  • File and printer sharing on
  • Password-protected sharing off
  • 128-bit encryption
  • Public folder sharing on
  • Same Workgroup (called "Multiverse")

All the folders (and printer) i need to share on Ravnica are shared, with Read permissions for "Everyone", with the Microsoft-account-linked user as an admin (which is the only named user on Ravnica)

Why are the clients being prompted for a password in this situation?

Extra data that may help, but i doubt it's relevant

The network is as follows:

{ISP wireless AP/switch/router} <-> {gigabit switch A} <-> {Powerline Adpator} ~~

~~ {Powerline Adpator} <-> {gigabit switch B} <-> {Ravnica}

~~ {Powerline Adpator} <-> {Ixalan}

{Innistrad} is either connected by wireless to {ISP wireless AP/switch/router}, or by a wire to {gigabit switch A} There are a variety of other non-PC devices attached to all three switches, including the TV, games consoles, a raspberry Pi, etc, but none are configured to use the network share.

EDIT: Just to clarify if either client types \\RAVNICA into an explorer address bar, then it is prompted for a password. I do not even get to see the shared folders.

The folders in question are not under {insert any drive letter here}:/users. The folders are all on the root of a secondary hard disk, and are not considered system folders

the following is set ravnica: enter image description hereenter image description here enter image description hereenter image description here enter image description hereenter image description here enter image description hereenter image description here enter image description here

  • Home Group is no longer being supported in Windows 10. Turn Public Folder sharing off and then see if you can make a folder c:temp (and allow "Everyone" to use it) and see if you can connect to c:\temp – John Oct 23 '19 at 14:35
  • Hello, thanks for updating information. Based on your edit, what happens if the clients type \\RAVNICA\Anime in the address bar instead of just \\RAVNICA i.e. do not attempt to list the shared folders? (Similar to the Map network drive option) Do they still get the login dialog? Also, what happens if the OK button in the login dialog is directly clicked without entering any credentials? – ManSamVampire Oct 24 '19 at 10:24
  • Also, if you have a non-windows device on the same network (for eg. a PC with Linux/Mac or a phone) please try accessing the share using an SMB client on this non-Windows device and select the login anonymously or any similar option and find out if the share is accessible. This will help us understand if the problem is on client's side or server side. – ManSamVampire Oct 24 '19 at 10:28
  • @ManSamVampire So i did the windows side tests you asked: No user-pass just re-prompts the same dialog, asking for \\Ravnica\folder gets me a "windows cannot access [path]" dialog. I'll do a SMB test on my RPi over the weekend. – Force Gaia Oct 24 '19 at 20:58
  • I still don't understand why there is a problem. I tried to create a similar share on my own network and it works without any problems. Is any of the PCs connected to a domain? Any group policies set? Also, what happens when you create a similar share (with password-protection disabled) on the client-PCs Innistrad and Ixalan, can you access them on Ravnica without entering a password? – ManSamVampire Oct 26 '19 at 12:01
1

I would like to inform you that simply disabling password-protected sharing does not make a share accessible to everyone without prompting for a password.

To make a share accessible openly, you have to perform all the below operations -

  • Turn off password protected sharing in Settings → Network → Sharing options → All networks
  • Make sure that the file system permissions on the folder allow unrestricted access to it
    Right click the folder → Properties → Security tab → Advanced → Permissions tab → Make sure you grant at least Read permissions for the Everyone user account
    If the Everyone account doesn't exist, you can add it using the Add button.
    (You might also want to check the Replace all child objects permission entries with inheritable permission entries from this object option if you want to recursively allow access to all folders inside it without manually configuring the permissions of the children.) Filesystem permissions window
  • Provide permissions for the shared item to be accessible to all users

    • Right click the folder → Properties → Sharing tab → Advanced Sharing → Permissions → Make sure you grant at least Read permissions for the Everyone user account.
      If the Everyone account doesn't exist, you can add it using the Add... button. Advanced permissions window

    • You can also perform the above step by re-creating the shares using the net share command.

      net share sharename="path" /grant:Everyone,PERMISSION
      

      NET SHARE command example

  • 1
    You might also need to add 'Everyone' group with read access to the security permissions of the folder being shared too (and replacing all child objects with inheritable permissions from that folder), pretty sure it's least permissive. – Smock Oct 23 '19 at 14:59
  • 1
    Thanks, I missed this - will update it in the answer – ManSamVampire Oct 23 '19 at 15:02
  • Make sure the folders being shared are not in USERS as newest Windows 10 security prevents that. Best to use neutral folders not in USERS for sharing purposes. Then share to "Everyone" as I and others noted above – John Oct 23 '19 at 15:06
  • All bar the netshare on the command line are what i have already done as specified in the details of the question. But i get the feeling one small detail has been missed so I'm gonna update the question for clarification – Force Gaia Oct 23 '19 at 23:50
  • @ManSamVampire updated OP, so you can see all of that was already set – Force Gaia Oct 24 '19 at 0:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.