0

I run Windows 10 Pro, nothing special about the set up. Been using the PIN system for about a year or so when suddenly I got an issue. Anytime I access the store or xbox apps, it would request the PIN. Here I would get stuck in a loop. Specifics on the loop are below.

I tried resetting group policies, security settings, and resetting windows itself to no avail.

After deleting the NGC folder (C:\Windows\ServiceProfiles\LocalService\AppData\Local\Microsoft) I was able to access the Store, this time it requested my standard MS/Win password. No looping.

When i try to set up the PIN again, I get the loop. I then tried reinstalling windows and again I get the loop when I attempt to set up the PIN.

Any ideas how I can get round this? I can use my password for now, but I would like to use the Hello PIN if possible.

The Loop:

The loop itself occurs when I get this screen:

https://i.stack.imgur.com/6XSG4.png

Selecting ANY option, whether it is entering a PIN, clicking OK / Cancel, or closing the dialog itself, will result in a second delay then the same dialog opens up again. When I already had a pin set up, it just asked for input (instead of setting up a new pin). It didnt matter if I typed the pin in correctly or not, the box would disappear and then immediately re-appear.

The only way to get out the loop is to close the process in the taskbar.

EDIT: In Addition, when i try to switch to a local account I get this error, perhaps indicating the problem is with account settings on my PC somewhere?

https://i.stack.imgur.com/AMtdB.png

Another edit: I tried MS Help and the only thing they could come up was to create a new user account (which worked). I would rather keep my old one so I do not have to reinstall all my tools and get authentication token etc.

I did find this report in event logs whenever I try to set the PIN:

Faulting application name: CredentialUIBroker.exe, version: 10.0.18362.1, time stamp: 0x38c5a224
Faulting module name: ntdll.dll, version: 10.0.18362.418, time stamp: 0x99ca0526
Exception code: 0xc0000374
Fault offset: 0x00000000000f9269
Faulting process ID: 0x5d44
Faulting application start time: 0x01d58bc991337e8b
Faulting application path: C:\Windows\System32\CredentialUIBroker.exe
Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll
Report ID: a47fe8b6-ade4-4d7f-a146-f106642940bb
Faulting package full name: 
Faulting package-relative application ID: 
0

I cannot guarantee this will work for everyone, it may be just dumb luck, but this is how I stumbled upon a solution.

As I mentioned in the Q I removed the NGC folder content, I then created a new account (local) and verified PIN was working. Then I added an MS account to it (essentially replicating my problem account). Again I verified the PIN etc was working.

At this point you could just switch to the new account, but that wasn't acceptable to me so I did a lot of "faffing about". I discovered that if I deleted the new account completely and switched back to the old one, the new NGC folder remained. Sadly, so did the problem.

I went to the Credential Manager (Control Panel\All Control Panel Items\Credential Manager) and removed a few older tokens (sorry can't remember them all), but made sure to remove my MicrosoftAccount and Skype tokens, basically anything that smelt Microsofty. Then I deleted the new NGC folder content and rebooted.

Suddenly it just worked again. I tried to remove my account and go local and that seems to work too. So I assume the NGC might not have helped and it was just a corrupt credential?

Any any rate, I have put everything in I could remember in case it helps a fellow browser someday. If someone out there can tell me why this would work, when I tried all the steps before individually, then please relieve me of my ignorance!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.