0

I recently reinstalled Windows on my SSD and it is now refusing to update to 1903 with an error of 0x800703EE without further description. This error was asked several times on SU, but with no good answers, because none of the answers in Getting error 0x800703ee when trying to upgrade Windows 10 works for me. Notice the OP of that post never did accept an answer.

Here are a few points regarding my situation:

  • My Windows is version 1809
  • I have a dual boot Ubuntu on my system.
  • I have messed with the booting partition. I have used AOMEI to shrink my Windows primary partition. Fast boot is off. I accidentally deleted the boot partition, and reconstructed it according to: http://woshub.com/how-to-repair-deleted-efi-partition-in-windows-7/?fbclid=IwAR1MFp_OuUlVYvESLu9-_hNdDqzubRsYd-dfNMpynjYTShyYDBJJGj0I0a0
  • Other cumulative Windows Updates were successful.
  • I have run sfc /scannow and Dism /Online /Cleanup-Image /RestoreHealth. It did fix a problem, but they both says my PC is fine now.
  • Online searching has lead me to believe the error code might be the one related to: "The volume for a file has been externally altered such that the opened file is no longer valid." However, I do not see this message explicitly in any log

Can anyone help with this error? I'd love to provide more information.

enter image description here

The associated XML description:

Log Name:      System
Source:        Microsoft-Windows-WindowsUpdateClient
Date:          10/25/2019 12:35:40 AM
Event ID:      20
Task Category: Windows Update Agent
Level:         Error
Keywords:      Failure,Installation
User:          SYSTEM
Computer:      COMPUTER NAME
Description:
Installation Failure: Windows failed to install the following update with error 0x800703EE: Feature update to Windows 10, version 1903.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Microsoft-Windows-WindowsUpdateClient" Guid="{945a8954-c147-4acd-923f-40c45405a658}" />
    <EventID>20</EventID>
    <Version>1</Version>
    <Level>2</Level>
    <Task>1</Task>
    <Opcode>13</Opcode>
    <Keywords>0x8000000000000028</Keywords>
    <TimeCreated SystemTime="2019-10-24T16:35:40.975484800Z" />
    <EventRecordID>49631</EventRecordID>
    <Correlation />
    <Execution ProcessID="5052" ThreadID="1468" />
    <Channel>System</Channel>
    <Computer>COMPUTER NAME</Computer>
    <Security UserID="S-1-5-18" />
  </System>
  <EventData>
    <Data Name="errorCode">0x800703ee</Data>
    <Data Name="updateTitle">Feature update to Windows 10, version 1903</Data>
    <Data Name="updateGuid">{c6a0bbfe-fa2b-4d86-aab4-fb51f87b459e}</Data>
    <Data Name="updateRevisionNumber">1</Data>
    <Data Name="serviceGuid">{8b24b027-1dee-babb-9a95-3517dfb9c552}</Data>
  </EventData>
</Event>

WindowsUpdate.log excerpt

2019/10/25 00:48:44.3218564 5052  1468  DownloadManager *FAILED* [8024000C] DynamicDownloadDataFetcher Refresh complete
2019/10/25 00:48:56.1837108 5052  11392 DownloadManager ExtractUpdateFiles
2019/10/25 00:48:56.2338791 5052  11392 DataStore       Service 8F9D09EA-B8FB-4BD8-A7B9-281E08077B5A removed
2019/10/25 00:48:56.2338909 5052  11392 Agent           RemoveTargetedServiceMapping: 8F9D09EA-B8FB-4BD8-A7B9-281E08077B5A -> 7971F918-A847-4430-9279-4A52D1EFE18D
2019/10/25 00:50:07.5218089 9716  7000  Handler         Install complete for update ID: C6A0BBFE-FA2B-4D86-AAB4-FB51F87B459E.1 Return code is 0x800703EE. Requires Reboot:No
2019/10/25 00:50:07.5218108 9716  7000  Handler         Enter deployment handler NotifyResult
2019/10/25 00:50:07.5219540 9716  7000  Handler         Leave deployment handler NotifyResult
2019/10/25 00:50:07.5219570 9716  7000  Handler         *FAILED* [800703EE] Leave deployment handler Install
2019/10/25 00:50:07.6358057 5052  14980 Agent           LogHistory called. idUpdate={C6A0BBFE-FA2B-4D86-AAB4-FB51F87B459E}.1, resultMapped=800703EE, resultUnMapped=0
2019/10/25 00:50:07.6365964 5052  14980 Agent           Install updates CallerId = UpdateOrchestrator
2019/10/25 00:50:07.6367390 9236  3124  ComApi           Install ClientId = UpdateOrchestrator

enter image description here

Screenshot of AOMEI Partition Assistant:

enter image description here

GParted Screenshot:

sdb3 contains the Windows Boot loader. sda3 contains GRUB, I believe, whatever that boots up Ubuntu.

enter image description here

enter image description here

13
  • 1
    Possible duplicate of Getting error 0x800703ee when trying to upgrade Windows 10
    – Moab
    Oct 24 '19 at 17:04
  • Please post a shot of the drive in Disk Management.
    – Moab
    Oct 24 '19 at 17:05
  • @Moab Yes, I also think so. But that post is pretty much dead now. Oct 24 '19 at 17:06
  • @Moab posted drive shot. Oct 24 '19 at 17:08
  • Error 0x800703EE carries the text "The volume for a file has been externally altered so that the opened file is no longer valid". Oct 24 '19 at 17:10
0

One remark I can make is that your EFI partition is too small for Windows 10. It should be at least 500 MB. I suggest to resize some partition on the boot disk so as to leave at least 1 GB of unallocated space, then try again.

If this doesn't help, then something is messed up in Windows and it would be pretty hard to analyze what went wrong. You have already tried all the standard advice given for such problems, without solution. It is possible that this was caused by the Linux installation, if it ever modified anything on the Windows partition.

I would suggest to use the Media Creation Tool to do an offline upgrade of Windows in order to set all components to a known state. This might short-circuit the dual-boot with Linux, so you may need to fix that afterward.

For more information, see the article
How to Do a Repair Install of Windows 10 with an In-place Upgrade.

In case that the problem still arrives, try doing this while booting in Safe mode.

6
  • I checked with GParted and my Windows EFI is still having around 80MB free disk space though. Oct 24 '19 at 17:41
  • In my experience, if installing a feature upgrade fails through Windows Update, it will also fail with the upgrade Assistant and the Media Creation Tool. The process to download and install the feature update is identical using all three methods.
    – Ramhound
    Oct 24 '19 at 17:43
  • 1
    The 80MB free disk space relates to the currently installed version. Windows 10 itself now allocates 500 MB whenever it has the space for it.
    – harrymc
    Oct 24 '19 at 17:46
  • @harrymc - You sure about that? I have a fresh installation of WIndows 10 version 1903 and my EFI partition is only 100 MB. Infact looking all my systems I don't have a single system with a 500 MB EFI partition.
    – Ramhound
    Oct 24 '19 at 17:49
  • @Ramhound: I only have 500 MB partitions, and this same advice worked for other posts here, so I would still advise it (even if it is not the problem here).
    – harrymc
    Oct 24 '19 at 17:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.