I have a network share that I access daily from both a Windows laptop and a MacBook Pro. The Pro (or rather the VLC app) keeps insisting on creating a ._<file name> file for every video that I open from this network share on the Pro.

How can I prevent these files from ever being created? I've spent 2 hours researching this before giving up, and deciding to just delete them from the Windows side instead, since I already have a batch script set up to automatically map the share to a drive letter on startup.

But this has proved to be even more difficult! I've tried Get-ChildItem -Path V:\._* -Recurse -Force | Remove-Item but this results in Remove-Item : Cannot remove item <file name>. You do not have sufficient access rights to perform this operation.

So I've tried several variations of $acl = Get-Acl <known good file>; Set-Acl -Path <file that won't f*** off> -AclObject $acl, but those commands all come back with Set-Acl : Some or all identity references could not be translated.

I'm almost at my wit's end over this! Somebody please save me from this madness!! MTIA :-)

P.S: I'll accept a solution that works from either side (Mac or Windows) but preferably it would be awesome if these files never got created in the first place. Thanks again!

UPDATE: Here's a screenshot of the folder permissions in Windows:

Root folder permissions for the mapped network drive in Windows

I set the owner explicitly just now, and tried removing the other two ACLs through that window, but no dice...they just come straight back when hitting 'Apply'! :@

I also can't add perms. from the local computer...the dialog will only allow me to choose the network address under 'Locations':

Trying to add permissions for a local PC user fails as well

And here's the share tab as requested by @ErjenRijnders:

Share tab of permissions window...useless!

My router is pretty much the cheapest, most run-of-the-mill one that my ISP gives its customers for free, so I'm surprised it even supports all of this, let alone more LOL.

  • Possible duplicate of Is there any way to prevent a Mac from creating dot underscore files? BlueHarvest is imo the best 'set & forget' option; many of the other answers would require manual intervention or some kind of cron/bat action.
    – Tetsujin
    Oct 25, 2019 at 7:13
  • 1
    @Tetsujin Thanks mate! Always the "fastest gun in the West" ;-) I'd actually prefer a scriptable solution to a third-party app that I have to install just for this purpose. I'll check out that other question that you linked to. Cheers again! Would upvote your comment if I could but I guess that requires more than 13 rep...?
    – Kenny83
    Oct 25, 2019 at 7:27

1 Answer 1


Is your network share running on a Windows File server? Than make sure that the directory where the files are created have sufficient permissions for the user that is trying to delete the files. So mstsc to the remote server, open the share locally like C:\share and check permissions. That means you need give the user SMB and NTFS permissions, not one of them because you are trying to delete it from a network share. This also counts for a Linux share, make sure it has the right NFS permissions as well.

You can also try to run the same command from an elevated command prompt.

Probably the best option is to tell the server (if it's Windows Server) to actually execute the command like this:

Invoke-Command -ComputerName Server01 -ScriptBlock { Get-ChildItem -Path V:\._* -Recurse -Force | Remove-Item }

More information about the invoke-command: https://docs.microsoft.com/en-us/powershell/module/microsoft.powershell.core/invoke-command?view=powershell-6

  • Cheers buddy! It's actually a USB drive plugged into my router LOL, so that complicates things exponentially. If it was a real computer, I wouldn't have even bothered you fine folks ;-)
    – Kenny83
    Oct 25, 2019 at 7:32
  • you can still check the permissions, right click and check sharing and file permissions. If you are sure your user has sufficient permissions, try to remove again. Or try assign permissions by your Windows file explorer. Or can't you even check it that way? Maybe share some screenshots? Oct 25, 2019 at 7:36
  • LMAO I beat you to it by 5 secs! See update :-)
    – Kenny83
    Oct 25, 2019 at 7:37
  • How about the permissions of a ._<file name> itself? Try to enable "Replace all child object permissions entries with inheritable permission entries from this object". Also share a screenshot of the "Share" tab. Oct 25, 2019 at 7:41
  • I think the problem is with the sharing tab. You are trying to remove a file using SMB permissions (as your router uses SAMBA). If you can't get those permissions set correctly, it won't work. Maybe login to your router login page and see if there is a module that can manage your share. Or if you are more advanced, try to install OpenWRT on the router (double check the supported list). It has much more flexibility and can manage Samba. openwrt.org/docs/guide-user/services/nas/samba_configuration Oct 25, 2019 at 7:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.