0

I have a supposedly bricked HP LaserJet M276nw, likely through a failed firmware update, as I learned from HP's forums.

I thought I would be clever and replace the mainboard (formatter board), which has the ROM chip on it, with one from a working model which had a cracked scanner glass. But, upon swapping this board in, the printer still hangs during boot. Connecting the printer to a Win10 computer at any point during its boot fails to allow it to be recognized as a device. Additionally, installing the drivers using HP's tool requires connection of the printer partway through, likely to add the printer to the Windows list of devices. For reference, I have no computer that has ever had the printer installed on it.

But, while I was replacing the mainboard, I noticed a jumper on it that says 'firmware update'. I added a jumper here and turned on the printer, and it says "Ready 2 Download", which is promising. HP has a utility for installing the firmware, and from what I can tell, it sends a 'file to be printed' to the printer, which you select from a dropdown menu, consisting of the updated firmware and a few instructions to write it to the ROM chip.

Connecting the printer to my computer over USB in this "Ready 2 Download" state adds two new USB controller devices:

  • USB Printing Support
  • No Printer Attached

Very promising! Yes, there's a USB device called 'no printer attached' in the device manager. I checked the registry and found that this is a nicename of a 'generic printer', which saw that this was on port USB001. So I added a dummy printer on this port using the proper drivers from HP, and tried to use HP's firmware updater. This unfortunately failed to send anything (the spooler timed out during send).

So with all that setup, to my specific question:

I have a printer using the right drivers for my M276nw in the windows printer list. I also have a device connected and 'recognized' by windows as a USB device with a specific address. I feel that if the firmware updater were able to spool to this generic device, the printer might receive the firmware.

  1. How can I connect these two logical bits, and have the printer I added spool to this specific USB device? e.g., is there a way to set the generic device's hardware ID to match what the printer driver expects?

  2. Failing that, how might I set up this generic USB device (no printer attached) as a generic printer?

  • Does the printer power up to a "Ready" state? Can it print any of the internal test pages (config page, service pages,...)? And, why do people always want to upgrade printer f/w? Do that only when you KNOW the new f/w offers something you want. – hdhondt Oct 26 '19 at 9:06
  • The printer halts during its boot and will not come to a ready state. This is why I'm trying to redo the firmware, since the installed firmware is corrupt. – Andrej Oct 27 '19 at 11:17
  • Try a factory reset, as shown here: youtube.com/watch?v=WTCJ9fvKRz8 The instructions are in the text below the video. – hdhondt Oct 28 '19 at 8:48
  • Definitely tried that a dozen times – Andrej Oct 29 '19 at 11:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.