The amdgpu-pro docs (https://amdgpu-install.readthedocs.io/en/latest/) mention that Mesa multimedia files are installed with the amdgpu installation. I had Mesa working, but wanted to install amdgpu-pro. (Let's avoid the topic of whether it was a mistake or not to want such a thing.) amdgpu-pro has totally borked my graphics.

Is there a way to uninstall amdgpu-pro without killing Mesa support at the same time?

Some details: OS: Debian 10 AMDGPU-PRO version: most recent Ubuntu (Oct 2019) GPU: rx580

Some attempts: sudo amdgpu-pro-uninstall doesn't give me my graphics back, and if I do sudo apt purge amdgpu* (from the console in recovery), I lose the Mesa support.

2 Answers 2


A huge thanks to freenode's #dri-devel , @kostix, and this article.

Here's what worked for me in the end, through a ton of trial and error. I must confess that I don't know if all of the installs are necessary, but I followed the article I linked above on the same run as I removed amdgpu*, so I don't really know what precisely made it all work. It may be that apt remove didn't take out the drivers that Mesa needed, or maybe libdrm-amdgpu1 and xserver-xorg-video-amdgpu were enough (especially once using only apt remove. If you're using this hands-on, I sincerely doubt that you need to install Vulkan (the second line of installs), but I can't see it hurting either, so I'm keeping it in for now.

apt remove amdgpu*
apt install libdrm-amdgpu1 xserver-xorg-video-amdgpu
apt install mesa-vulkan-drivers libvulkan1 vulkan-tools vulkan-utils vulkan-validationlayers 

(I have no experience with recent AMD support on Debian so my answer will be a bit generic.)

I would do something like this:

  1. Run dpkg -l '*mesa*'|grep ^.i to list the installed packages which have "mesa" in their names.

  2. Uninstall that AMD thing using whatever method fits best (purging looks like a good approach).

  3. Re-check what mesa-related packages you still have installed.

    If anything seems to be gone compared to the list obtained on step 1, install it by apt install.

Note that all APT operations get logged in /var/log/apt/history.log, so if purging that AMD stuff leaves you w/o graphics (you did not tell which precisely—no way to run X and/or Wayland or no 3D (OpenGL)), a way to recover is to read the tail part of that log file to find out what packages were uninstalled and try installing back those which look relevant.

Also note that the problem might be not with Mesa but with plain X.org driver for AMD hardware—Buster has at least the following packages which provide drivers for AMD video cards:

  • xserver-xorg-video-amdgpu: X.Org X server — AMDGPU display driver
  • xserver-xorg-video-ati: X.Org X server — AMD/ATI display driver wrapper
  • xserver-xorg-video-radeon: X.Org X server — AMD/ATI Radeon display driver

…and it may so happen that that AMD thing you've installed declares a conflict on any/all of these packages so they get uninstalled when that thing is installed, and to regain F/OSS driver for your card you need to install some of these packages.

  • I can get a console, but no graphics (recovery mode only) Oct 27, 2019 at 14:28
  • Your answer helped me get to something that worked. In the end, using just apt remove amdgpu* and installing some other drivers worked. I want to detail the process in case anyone else is suffering from similar issues, but I want you to know that this really helped me get there. Thanks! Oct 27, 2019 at 15:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.