3

My work PC has Windows 10. I'm allowed to use a personal mouse and attached a three-button cordless Logitech T400. It works fine, even though according to Logitech it's "not supported on Windows 10."

The middle button opens the Windows Start Menu, so it's clearly being recognized by the OS. However, I'd like the middle button to go through to the software I'm using, which (as someone who uses Unix remotely, X-server, and the terminal emulation software Putty and so on) uses the middle button constantly for pasting.

On older OS's, installing Logitech drivers gives you a few panes' worth of configuration options, one being to handle middle button differently. I've installed Windows 10 SetPoint and Unifying from Logitech, but neither was needed to get the mouse working (it worked fine from the beginning) and neither has the options I need.

After several hours of web-surfing, I've had two likely-looking ideas. The first is a Windows utility program, "Mouse and Keyboard Center 12." However, when unpacking the download it issues an error message: "Setup cannot continue because one or more of the required installation files are missing of damaged. Run Setup again from the software CD-ROM or another reliable installation source." I'll follow up on that.

The second is a long-standing and well-thought-of utility called X-Mouse Button Control 2.18.8 available at http://www.highrez.co.uk/downloads/XMouseButtonControl.htm I've installed this software and it is "working"... kind of. I've configured a terminal emulator Mobaxterm to "paste on RIGHT click." Now, I have a Thinkpad-style trackpoint USB keyboard with three buttons. And when I tell X-Mouse that Middle Button should generate event Right Click, I indeed get the paste I want! This shows X-Mouse is translating events. And if I leave Middle Button as " No Change (Don't Intercept)" and MobaXterm is not set to paste on right click, the middle button event gets through to the terminal emulator. The middle button also gets through to an emacs (an editor program) window running via Moba's X-server functionality.

However, the Logitech's middle button is still for some reason opening the Windows 10 Start Menu!!! Using X-Mouse to translate Middle Button to "Right Click" has no effect. Middle Button opens the start menu anyway. But when I try to use X-Mouse to direct the Right Button to generate a Left Click, THAT works. For instance double-right-clicking a word in a MobaXTerm selects it, just as double-left-clicking is expected to do.

My working theory is that there's some process, utility, setting, or something, that is turning the Logitech middle-clicks into SOMETHING (Left Windows Key??) before the X-Mouse Button Control utility is even getting the event.

Any ideas what that could be?

4
  • AutoHoyKey can map any key.
    – Biswapriyo
    Oct 29, 2019 at 6:19
  • Is there any change when booting in Safe mode?
    – harrymc
    Oct 29, 2019 at 16:04
  • Have you installed the Logitech mouse software, or attempted to?
    – Moab
    Oct 29, 2019 at 20:15
  • Logitech has no Windows 10 drivers for the T400, but my guess is that is because the standard drivers work perfectly. Again note the mouse works COMPLETELY and PERFECTLY. Pointer moves smoothly. The standard left and right button work. The scroll wheel works perfectly. And even the middle button is infallibly recognized by the OS. The only problem is that the OS--or some utility??--intercepts it and turns it into a Left Windows Key, or at least it acts as if that's what's happening. Oct 30, 2019 at 0:38

2 Answers 2

0

I would follow this flow map to begin with, and if it does not work let me know, in as much detail is available and we can go from there.

Settings > Devices > Mouse > Additional Mouse Options (under related settings) > In Device Settings you should see your peripherals software click on it and then click settings > From here you should see a BUTTONS tab which you can expand and then edit the functions of each one of the interactive parts of your device.

Hope it works, if not we can figure something else out!

2
  • 3
    Leo, from "Additional Mouse Settings" I get the "Mouse Properties" dialog. Tabs are: Buttons, Pointers, Pointer Options, Wheel, Hardware, SetPoint Settings. (The last tab, if clicked, opens the Logitech SetPoint software which simply shows options for support, update checking, their Bluetooth software Unifying which is just about Bluetooth not mouse events, and so on. The Buttons tab only has options for switching primary and secondary buttons, double-click speed, and ClickLock (some accessibility feature unrelated to the middle mouse button). Oct 30, 2019 at 0:43
  • The chain has broken. Where is the "Buttons" tab? I can follow from Additional mouse options, then you go to Device Settings. How to get there?
    – ndemarco
    Oct 16, 2020 at 17:30
0

I had a similar problem with Windows 10.0.18362.836. After a reinstall of the OS, middle mouse button was assigned to Windows 10 function. My solution was to deactivate the middle button and then reactivate it again.

In the mouse button settings, the function for the middle button was set to "Middle mouse button click". I then deactivate the middle button which worked fine and then switched the function back to "Middle mouse button click". Now other programs could take control over the middle mouse button worked expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.