7

tl;dr: Nearly 100% of my Windows and Chrome is in English and yet Chrome keeps displaying me Polish (my native, but not used by me in IT) version of pages. How can I prevent that?


I have Windows 10 1903, quite clean (installed a week a go), with full official updates and Chrome 78 with auto-updates enabled, so my stack should be fairly up-to-date.

Nearly entire of my system is in English:

  • Windows 10 was installed in English,
  • I have picked an English version of Chrome,
  • all apps installed on my PC are in English as well.

The only places where I have Polish enabled or used are:

  • input language / regional settings in Windows 10,
  • spell checking in Chrome.

Some screenshots:

enter image description here


enter image description here


enter image description here


Yet, each time I open a website that offers different language versions, Polish language is selected by default and I must always manually change it to English, which is pretty irritating.

I can see no option to control that in Chrome.

I can clearly remember that I've been using the same stack, with newest Chrome, but with Windows 7, with exactly the same configuration (i.e. whole Windows and Chrome in English, Polish used only for regional settings and spell checking) and it was working like a charm -- I had English pages and language as default when using Chrome.

When I expand Languages section in Chrome's settings then to my extreme surprise two languages:

  • Polish,
  • English (United Kingdom),

changes into three:

  • Polish,
  • English,
  • English (United Kingdom).

The order (if that matters) is as in the screenshot below:

enter image description here

This problem does not exists in other browsers, i.e. Edge always display English version of website in above described stack.

What am I missing?

8

Web browsers, including Chrome can specify that they accept web sites in multiple languages. This is independent of your system language but should usually default to the same.

There are web tools that allow you to check your request headers, for example http://www.reliply.org/tools/requestheaders.php. In your case you'll probably see pl being prioritized in Accept-Language.

You can change the weighting of those languages by expanding the "Language - English" option.

screenshot

  • Thank you for your answer. The page you have mentioned reports under my Chrome: Accept Language = en,pl;q=0.9,en-GB;q=0.8. Also, please see the edited question -- it turned out that I have two different English-like languages. I have changed order to have both of them as first and Polish as last and I will see, if that resolves something and eventually report here. Thank you. – trejder Oct 30 '19 at 8:21
3

Your order of the languages seems to place Polish as first in the order. You should move English to be the first one.

This is done in Settings > Advanced > Languages > Order languages based on your preference.

Click the three-points icon next to English and select Move to the top.

  • Thank you for your answer. Please see the edited question -- it turned out that I have two different English-like languages. I have changed order to have both of them as first and Polish as last and I will see, if that resolves something and eventually report here. Thank you. – trejder Oct 30 '19 at 8:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.