0

I have 4 PCs in my home, thus exists a LAN (All connected through wireless)

  • Mac
  • HP (Windows 8)
  • Acer (Windows 7 Ultimate)
  • Asus (Windows 10 - Home Edition)

Mac, HP, and Acer can see in peace within the same network all the rest of PCs. It through the Windows Network Explorer.

  • Note thus HP and Acer can see the Mac, and Mac can see these two mentioned and even the Asus

The problem is with Asus, it only can see the HP and Acer PCs, it never can detect and see the Mac.

I spent 2 days trying to figure out what is the problem or find some difference about HP and Acer against the Asus.

Thanks to God, I found the following:

  • HP and Acer has the following:

enter image description here

From above two important things:

  • The drop list shows: NetBios, SSDP, WSD
  • According to the list in the white part or background, I can confirm SSDP represents the router, WSD the windows machines (including the asus) and finally the NetBios (the shown in the bottom, represents the Mac pc)

Now, applying the same approach in Windows 10 (Remember Home Edition) I have:

enter image description here

Only appears SSDP and WSD.

Thus how configure Windows 10 to list the NetBios option?

Sharing the following too, it about IPv4:

  • For HP and Acer

enter image description here

  • Asus:

enter image description here

How you can see, the same configuration

Update: If I put in the address bar explicitly the Mac remote location, it works

enter image description here

Furthermore in the left pane of the Windows Explorer within the Network item then appears the Mac remote machine. If a new Windows Explorer is opened and is re scanned the network the 'problematic' scenario happens again, and is fix it once the Mac remote location is inserted in the address bar.

| improve this question | | | | |
  • First, what interface is this from exactly? Second, this sounds like case of a lack of NetBIOS support from the driver, if an option in the properties of an adapter is missing on one device but exists on another. – Ramhound Oct 31 '19 at 15:58
  • @Ramhound Windows Explorer -> Network and add the 'Discovery Method' column, such as "Name", "Category", "Workgroup" – Manuel Jordan Oct 31 '19 at 16:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.