5

Every few seconds a new .evtx file and a new .txt file appear in c:\windows\temp. Each .evtx file has nearly identical content (except for timestamps), ditto the .txt files.
The .evtx files are roughly 7 MB large and contain almost 3600 events each. As you can imagine, this is filling up the HDD rather quickly. We deleted ~30 GB worth of these files earlier today.

The entirety of the .txt files is:

Package full name = Microsoft.SurfaceHub_42.602.139.0_neutral_~_8wekyb3d8bbwe
AppXDeploymentServer version = 10.0.17134.1006
Result code = 0x80073CF6
Component failure code = 0x80080204
ETW Event ID = 7706
Deployment Operation = 4294967294
Package Manager State = 19
OSIM state = 2
Failed component name = windows.DeviceAccess

The .evtx files open in Event Viewer and mirror the sentiment of the .txt files: unable to install something or other related to the Surface Hub. Here's some excerpts:

The Appx package's manifest is invalid.: Cannot register package Microsoft.SurfaceHub because of a problem with Function element usage:FF0B 000C: Function requires a Device with a specific Id element, and cannot be used with an Id of "any"


AppxManifest.xml(98,10): error 0x80080204: Cannot register the Microsoft.SurfaceHub package because the following error was encountered while parsing the UnnamedExtensionHandler extension: The Appx package's manifest is invalid.
error 0x80080204: While preparing to process the request, the system failed to register the windows.DeviceAccess extension due to the following error: The Appx package's manifest is invalid.

I'm not sure where to start with this.
Can anyone point me in the right direction to begin troubleshooting this?

OS: Windows 10, latest Hardware: Surface laptop

I can provide additional details on request.

  • Are you installing the Appx package? Or is it already installed? Did you try to remove the app with Remove-AppxPackage in Powershell? Did you get the provider of those events? – Biswapriyo Oct 31 at 20:31
  • I'm not installing anything. I just went to check on a "disk out of space issue". I deleted a bunch of temp files and was about to be done when the disk space started evaporating again - tracked it to these files. I have not tried any remedies yet. I would like to understand the issue before poking at it. I don't see anything called "provider" in the event log, but the Source is "AppXDeployment-Server". – Sam Axe Oct 31 at 20:40
5

We were able to resolve this by removing the "Surface" app via powershell:

Get-AppxPackage *surface* | Remove-AppxPackage

Then reinstalling the "Surface" app from the Microsoft Store and rebooting a couple times.

Update:
The above method was a good first step, but after ~15 minutes the errors started coming back. Completely removing the "Surface" app and rebooting appears to have solved the issue.

3

Resetting the Surface app also solved my issues. Go to Settings, Apps (Apps & Features), search for "Surface", click on Advanced Options, scroll to the bottom and Reset. Then I also disabled Background apps (as recommended by previous comment). My free disk space now stays free and I love it!

1

Had the same problem today in my Surface Pro 5 (Windows 10 Pro 1803). Got a low disk space warning and after an hour realized that Temp directory was filling up (35 GB) with those .evtx files (even showed 0 bytes available in Local Disk).

For now, restoring the Surface app in Settings has worked, and those files have stopped appearing. Seems related to some bug or trouble automatically updating the app throuh Microsoft Store (it is happening with other apps: Low disk space after filling up C:\Windows\Temp with .evtx and .txt files).

Maybe even uninstalling the app would definitely solve this (actually, I don't know what this SurfaceHub app is for), but just restoring it has done the trick.

Will keep you informed if there are any news in next hours/days ;)

  • Thanks Javier. This was helpful. – Sam Axe Oct 31 at 21:17
0

I've fixed 2 of these issues today by updating the windows to the latest 1903 build. The removal of the App worked on 1 but didn't work for the other so just updated both. https://www.microsoft.com/en-us/software-download/windows10

0

On your Surface, go to parameters - applications- click on Surface - and then click on advanced options - reinitialize
Then turn off the background running of this application on the same page (translation from the french terms, the terms may be slightly different on yours ;) Problem resolved for my SurfaceBook :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.