2

I use Windows 10 Home, brazilian portuguese (upgraded from win 7, pt-BR too). I know that Windows makes a translation of its main folders to match the display language and be user-friendly to those who don't have English as its native language. I noticed today that other folders are translated but "Program Files" still appearing in english, and in brazilian portuguese, that folder is named as "Arquivos de Programas".

If it matters to this question, some time in the past, I downloaded the US english pack and used it as my default display language, just to study english actually and to be in contact with windows english version and names, so when I had to search internet about an issue, I only found content if it searched in english. From some months to now, I enabled brazilian portuguese back and removed english language pack, to get more comfortable using it.

I found some topics on internet from people saying that the desktop.ini file could be missing or corrupted.

How to get "Program Files" properly translated again as it should happen by default? Have you ever seen that issue?

UPDATE: I opened the desktop.ini file inside Program Files folder and here is its content:

[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21781
1

Your desktop.ini file is entirely correct. The parameter -21781 indicates only that this is the "Program Files" folder.

This is apparently a glitch because of the language pack changes.

I don't know of a solution, but you might try this:

  • Ensure that you are running the latest Windows 10 version 1903
  • Switch language to English
  • Reboot a couple of times
  • Switch to your language, deleting also the English pack (if possible)
  • Reboot a couple of times

I suggest to first create a System Restore point, to be able to return to your current state, just in case.

  • Hi, thanks for answering! Yesterday, I checked for windows updates and 1903 version was finally available, I run the update and now that freaking folder is correct for God sake :) - I didn't understand why that issue happened, I use windows for a decade and I never had that issue before. After 1903 build, windows moved its previous installation to a windows.old folder and now everything sounds fine. I take care of my Windows like a baby and yet it gets bugs. – joaogdesigner Nov 1 '19 at 17:50
0

I don't know why hell that happened, but after 1903 build being available to me, I updated and it fixed that issue. Windows always playing "trick or treat" with its consumers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.