0

My Dell XPS13 notebook will not read any FAT32 formatted drive, be it a USB flash drive or the bootable UEFI partition.

This is preventing me from:

  1. Updating Windows 10
  2. Entering Safe Mode
  3. Reading any FAT32 drive
  4. Re-installing windows

I've tried both UEFI (Secure Boot) and Legacy boot.

The screenshot below shows a known good 4GB, properly formatted FAT32 USB stick. EaseUS Partition Master recognizes as FAT32, Windows 10 Disk Management sees it as RAW.Partition Master however cannot read the disk contents. If I try to re-format the drive (or smaller drives) to FAT32, it fails.

enter image description here

Please !!! This computer will not read any FAT32 drive, USB, internal or external. The drives I try are all correctly formatted, and readable. I plug in a known, good drive, and the computer reports that it needs to be formatted. Trying to reformat to NTFS works fine, but a format to FAT32 fails, and the machine wants to format it again... etc etc.

I cannot re-install windows: because, All Windows 7/8/8.1/10 installation ISO files are designed to be extracted to FAT32.

Seems like a driver problem, but i dont know where the FAT32 drivers are ? Does anyone know?

  • 1
    What do updating windows, safe boot mode and reading FAT32 have in common? – davidbaumann Nov 2 '19 at 17:33
  • Why not format it NTFS? – Moab Nov 2 '19 at 20:17
  • Whare are the drivers for fat32? Are they in the bios, or Windows? What is broken that is causing any fat32 drive not to be readble. Another thing I notice is that every time the laptop boots up, there flashes up a warning.. scanning drives .... Repairing drives. – Martin Lintzgy Nov 6 '19 at 0:30
  • How will that fix unreadable fat32 drives? – Martin Lintzgy Nov 6 '19 at 0:37
  • @MartinLintzgy Are you cancelling the disk check during Windows boot up? If you're getting that every time you boot Windows, one of the drives likely has a hardware error (likely the USB drive). If the USB drive isn't plugged in during boot, do you still get a disk check at boot? (Windows natively supports FAT32) – JW0914 Nov 8 '19 at 13:27
1

It is possible that your windows might not be assigning letters to the drives properly. You should open run (windows + R), and then type 'diskmgmt.msc'. If you can view your drive there, just simply assign a letter to drive by right clicking on the partition of your usb drive and assigning it a letter.

|improve this answer|||||
  • If I do a ms config, on the boot tab, there is no bootable uefi media showing, and the safe boot checkbox cannot be selected. – Martin Lintzgy Nov 6 '19 at 0:36
  • Probably you have selected legacy only mode in bios.. – Bhavya Gupta Nov 7 '19 at 9:44
1

All Windows versions recognize FAT32, so it's likely its partition was created, but never formatted, else an error occurred during formatting or the drive is failing.

  • How is Windows able to boot if it doesn't recognize the EFI partition?
    (Disk Manager shows the EFI partition is recognized... it's partition 1 on disk 0)

Try formatting the USB Drive via DiskPart:

  1. WinKey+R
  2. Open: DiskPart
    1. lis dis
      • Ensure USB drive is Disk 1, else update #2 accordingly
    2. sel dis 1
    3. clean
    4. convert mbr
    5. cre par pri offset=1024
    6. format fs=fat32 Label=BUSBI
    7. assign letter=D

If this results with the drive still not having its filesystem recognized by Windows, the USB drive has a hardware issue and should be replaced.

|improve this answer|||||
  • This is not a linux machine, and of course i wait for disk check to complete. the reason why windows update always fails is Error 0x800703ed The error 0x800703ed means ERROR_UNRECOGNIZED_VOLUME: // // MessageId: ERROR_UNRECOGNIZED_VOLUME // // MessageText: // // The volume does not contain a recognized file system. // Please make sure that all required file system drivers are loaded and that the volume is not corrupted. // #define ERROR_UNRECOGNIZED_VOLUME 1005L .. and around in circles, because the unrecognized volume is the FAT32 formatted EFI drive. – Martin Lintzgy Nov 30 '19 at 11:13
  • And around in circles, because the unrecognized volume is the FAT32 formatted EFI drive. I think the driver is called Fastfat.sys, but how to install? i can only guess that it got corrupted or perhaps the ssd drive has a bad memory element? – Martin Lintzgy Nov 30 '19 at 11:21
  • just attempted to create a Re-install ISO from microsoft.com/en-gb/software-download/windows10 on to a flash drive. I formatted it to NTFS. The installer re-formatted to FAT32, useless. – Martin Lintzgy Nov 30 '19 at 13:52
  • @MartinLintzgy It would prove immensely helpful to you to simply to google this or search StackExchange, as this can be found within the first few links returned. The Media Creation Tool will format a USB as FAT32 to enable installing to a BIOS or UEFI system, and if you'd like to use NTFS, try Rufus; however there's no point using NTFS for a WIndows install USB, so I'm perplexed as to what the issue exactly is? – JW0914 Nov 30 '19 at 15:14
  • thank you for trying to help, JW0914 I have searched how yo install a windows ISO that is bootable from NTFS. I have found none. Rufus, as far as i can tell supports up to Windows 7. Could you please help by sending a link? – Martin Lintzgy Nov 30 '19 at 20:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.