1

I've created an AVD and trying to change it's setting for OpenGL ES 3.0, but whenever I press any of the buttons appearing on the side frame, it exits throwing the following error

Emulator: [24497:24497:1103/181158.243196:ERROR:zygote_host_impl_linux.cc(89)] Running as root without --no-sandbox is not supported. See https://crbug.com/638180.

Emulator: Process finished with exit code 1

I am using the latest version of Android Studio on Ubuntu 19.10 and API 28 for creating AVD. I am not finding any of the solutions for it. Please help me figure this out.
It would really be a great help. An exception occurs after pressing any of these buttons

enter image description here

4
  • Running as root without --no-sandbox is not supported. See crbug.com/638180.
    – DavidPostill
    Nov 3 '19 at 15:56
  • @DavidPostill that link defines the problem regarding chromium browser
    – JAMSHAID
    Nov 4 '19 at 1:20
  • Yes, but it's the same error you have
    – DavidPostill
    Nov 4 '19 at 6:46
  • yeah. It isn't working while running with --no-sandbox too. That error is relevant to the Chromium browser. How can the solution be the same for both tools?
    – JAMSHAID
    Nov 4 '19 at 12:53
1

You should be able to disable sandbox and fix this issue by setting environment variable: QTWEBENGINE_DISABLE_SANDBOX to 1:

export QTWEBENGINE_DISABLE_SANDBOX=1

See also same issue on stackoverflow: https://stackoverflow.com/a/60060618/3197518

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.