0

When i boot to Windows it tries to do an automatic repair but fails.
It shows a path to a log file SrtTrail.txt on the recovery partition but there is no System32 folder in the Winre.wim archive.

I tried running Boot-Repair with the MBR options enabled but the problem persists. I don't know if that helps at all because i don't use a MBR.

I tried fixing it with Bootrec:
When i run Bootrec /FixBoot i get an access denied error.
In the output of diskpart the letter c is assigned to another disk without any OS on it and d to the recovery partition (I assigned v in the screenshot). disk 0 is the disk without any OS and disc 1 the disc with windows on it. When i remove the disc where c was assigned, c is assigned to the recovery partition and d to the partition with windows (previous v). I swapped the letters, so that c is the partition with windows.
I tried formating the EFI partition with format V: /FS:FAT32 and running bcdboot C:\Windows /s V: /f UEFI but it can not copy C:\Windows (I can chdir into it and are files in it).
When i run Bootrec /ScanOs there are no identified Windows installations.
The options to reset Windows fail as well.

I tried a Timeshift restore of /boot/efi from before i used windows the last time (it was working fine back then) but that didn't help either.

I use multiboot with grub. When i change the partition that will be booted to the Windows Boot Manager in the BIOS there is the same problem.

The windows partition can be mounted in Linux without any problem and the files look ok.

Volume 2/V is the partition with Windows: DiscPart GParted

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.