0

I'm trying to set the startup type to Automatic in Windows Update Properties of Windows 10, but the error "Access denied" appears. How can I fix it?

I tryed also with the command "Net user administrator /active:yes" in the Prompt; the administrator modality is activated, but I get the same error when I try to do the forementioned action.

enter image description here enter image description here

Thank you in advance.

  • What exactly are you doing and what is the error. Please edit your post to add the information. Screenshots might help. – harrymc Nov 4 '19 at 10:44
  • Hello @harrymc, I want to update windows, but it does not work. I edited my question by inserting a screenshot, but it is in italian. – Gennaro Arguzzi Nov 4 '19 at 10:47
  • Why not go through Start > Settings > Windows Update settings*? – harrymc Nov 4 '19 at 10:55
  • See the other screenshot please. – Gennaro Arguzzi Nov 4 '19 at 11:07
  • 1
    Just an FYI, Local Administrator account is not required and should remain inactive and disabled, as it's a security risk to have it enabled since it's SID is well known. I could be wrong, but wuauserv isn't meant to be Auto started, but trigger started manually. As @harrymc mentioned, Settings should be utilized to force an update, however if you're trying to force upgrade to a bi-annual update, it won't always show up even though all prereqs are installed - simply use Microsoft's link to force it, clicking on Update Now – JW0914 Nov 4 '19 at 11:29
0

The Windows Update Startup type in Windows 10 is Manual, and there is no need to change it to Automatic for it to work. Actually, changing the Startup type to "Automatic" or "Automatic (Delayed Start)" might cause it to malfunction if it starts too early.

It is also doubtful whether such a change will keep, because Windows 10 surveys periodically the settings of Windows Update and will restore them from time to time.

If you wish to try and change this setting:

  • Start regedit
  • Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\wuauserv
  • Change Start to:
    • Automatic : 2
    • Manual : 3
    • Disabled : 4
    • Automatic (Delayed Start) : 2
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.