9

Since Brazilian daylight savings time rules changed, in places in Brazil where it was used, Slack Desktop in Windows or Mac is showing the wrong time (advanced 1 hour).

When I change slack timezone to a place where daylight savings doesn't apply following their info (Salvador for instance), in some places of the app the hour is shown correctly (eg. notifications), but on slack rooms they still show up wrong.

How to fix this?

2
  • it's very hard to restart slack because it doesn't quit, have you tried killing it using the process manager or rebooting? that should be sufficient to get it to reload the zone information.
    – Jasen
    Commented Nov 4, 2019 at 23:39
  • @Jasen Restarting after changing only slack timezone didn't fix it. I had to change Windows timezone as well, as stated in the answer below ;) Commented Nov 5, 2019 at 3:20

1 Answer 1

17

The key is to change also the computer clock to a different timezone where daylight savings doesn't apply (Salvador, for instance), and refreshing Slack (Ctrl+R did the trick for me)

Obs1: You don't need to be the slack admin to do this, it's related to your individual machine settings.

Obs2: Even if your time is showing correctly on your machine with your timezone set to Sao Paulo, for instance, slack will show incorrect time. You must set to a location with no daylight savings information, such as Salvador. Slack apparently uses that info instead of the current machine time.

3
  • 1
    Works for Linux too. I've changed my TZ to Recife and the problem is solved.
    – BrunoF
    Commented Nov 21, 2019 at 11:01
  • 1
    change macOS Time Zone from Brasilia to Salvador and restarting Slack did the job for me
    – zok
    Commented Jan 7, 2020 at 15:06
  • 1
    Windows: Changing my machine TZ to Salvador and restarting Slack fixed it
    – BrunoLM
    Commented Nov 10, 2020 at 16:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .