2

I am experiencing a problem with windows update. The install will fail at about 60-70% and roll back to a previous version of windows. I’ve attached the logs from the latest attempt at an install of update 1803. It fails with error code 0x800704c7, but I wasn't able to find anything that was particularly useful with that error code that I hadn't already done.

I have already tried the following:

Running the Windows 10 Update Assistant (results in the same problem as running the updates otherwise.

Running Windows Update Troubleshooter and Resolving All Issues before retrying the install.

Downloaded latest Servicing Stack Update

Downloaded the latest KB

Used DISM tool to ensure there was no image of file corruption

Stopped update services and cleared the software distribution folders before retrying the update from scratch.

Update failed again, attached Windows Update Log from the last update.

In all cases, the update runs for a while, gets to about 60-70% with multiple restarts then rolls back.

Log is in pastebin here

UPDATE: None of the recommendations helped. Issue was solved by a a full reinstall of windows (repair, recovery, in place update, etc all did not help). Three other laptops made from the same image also had this issue, so something got thoroughly broken when they were imaged originally.

  • 2
    Why upgrade to 1803 and not to 1903? Have you tried offline upgrade? – harrymc Nov 5 '19 at 14:54
  • 1
    @harrymc's answer about doing a repair install should fix the issue, but I would try cleaning the component store first, as a dirty component store will prevent Windows' updates: WinSxS cleanup: dism /online /cleanup-image /startcomponentcleanup, once done: dism /online /cleanup-image /restorehealth, reboot if any corruption is found/fixed, then sfc /scannow, reboot if any corruption found/fixed, then retry update. You can also bypass Windows Update altogether via using Microsoft's update site's Update Now button – JW0914 Nov 5 '19 at 15:14
  • 1
    @JW0914 I have previously followed those steps, without success. – Marshall Tigerus Nov 5 '19 at 15:20
  • 1
    @MarshallTigerus You ran the first command w/ parameter /startcomponentcleanup? If not, the latter two must be re-run in the order listed, as each of the three is sequential, depending on the other. /StartComponentCleanup ensures the WinSxS directory [Windows Component Store] is correctly configured for the updates currently installed. /RestoreHealth verifies there's no corruption in WinSxS by checking hashes against known good copies via Windows Update - WinSxS contains a backup of all system files. SFC /ScanNow verifies all files in %WinDir% against the known good copies in WinSxS – JW0914 Nov 5 '19 at 15:38
  • 1
    Microsoft Doc: Manage the Component Store explains in more detail about WinSxS (%WinDir%\WinSxS) for a better understanding of what it is. – JW0914 Nov 5 '19 at 15:43
2

Windows Update on your computer seems to have a problem accessing the latest version.

I suggest to force the issue by doing offline upgrade to version 1903.

For details see the article How to Do a Repair Install of Windows 10 with an In-place Upgrade.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.