2

When trying to install Windows 10 using a USB pen drive, I get the following message:

enter image description here

A media driver your computer needs is missing. This could be a DVD, USB or Hard Disk driver. If you have a CD, DVD or USB flash drive with the driver on it Please insert it now.

Note: if the installation media is in the windows DVD drive or on a USB drive, you can safely remove it from this step.


I already tried many suggestion described on Microsoft forums and on SuperUser as well, here and here, like:

  • use only USB 2.0 pen drives
  • use only USB 2.0 ports
  • cancel the error, return to the initial screen, change USB port of the pen drive and try again
  • create the pen drive using different tools
  • downloaded the ISO at least 4 times from Microsoft and re-created the pendrives, to ensure that it isn't corrupted
  • copied all drivers from the motherboard to another pen drive and forced Windows Install to find them. But even after it finds them, browsing one by one (by hand), it doesn't continue and the error persist

Now I'm testing with another pen drive and I will post here the results.


Update about installing the SATA driver:

I have tried it again but, as the results from previous attempts, even installing all the drivers that come from the "SATA" driver, after it the error persist and I can't proceeed with the installation.

enter image description here

The error message is: No new device driver found. Verify that the installation media contains the correct drivers and click OK.

  • Do you by chance have a RAID functionality enabled? The driver is not actually the SATA controller driver, that is built-into Windows, what isn't enabled is Intel RST and/or NVMe support deepening on factors. Please translate all non-English text to English if you want an verbose answer. – Ramhound Nov 6 '19 at 18:43
  • @Ramhound , the RAID feature wasn't enabled on BIOS. And, without any modification, using a new pen drive, a redownloaded ISO, written on an Windows computer through Rufus, it worked. – Paulo Coghi - Reinstate Monica Nov 8 '19 at 13:38
  • I detailed the solution on my answer. – Paulo Coghi - Reinstate Monica Nov 8 '19 at 13:38
1

You need the sata driver, go to this link and download the sata floppy image file, unzip it and when prompted to load 3rd party drivers, point it to the files.

https://www.asrock.com/MB/AMD/A320M-HDV/index.asp#Download

If this does not work, then remake the install media with a fresh copy of the iso image of W10.

| improve this answer | |
  • imgur.com/a/i2D0YqS It doesn't work. The link to the SATA driver on the Asrock site points to a file named "SATA/Floppy(v9.2.0.120).zip". Windows Installer found drivers on the folder with this "floppy" driver, but inside it there are only AMD-RAID drivers: bottom device, config device, controller device, controller storport and multi device. After installing all those drivers, the error persist. – Paulo Coghi - Reinstate Monica Nov 6 '19 at 16:33
  • Unfortunately I cannot read that language in the screenshot. It could be a corrupt iso image used when creating the install media. – Moab Nov 6 '19 at 16:39
  • It is written: No new device driver found. Verify that the installation media contains the correct drivers and click OK. – Paulo Coghi - Reinstate Monica Nov 6 '19 at 16:47
  • You might have the SATA Controller Disabled in the Firmware (BIOS/UEFI). Please check the firmware settings and reset them if required and try again. Keys like F2 or Delete at the startup boot logo will allow you to access the firmware settings. – patkim Nov 6 '19 at 17:15
1

What solved the problem in my case:

  1. I chose a new pen drive, and set aside all the others I had used before
  2. For Windows ISOs, I decided to use Windows computers to write them, not Linux as I was doing before
    • On Linux, it seems that Gnome Disks, MultiWriter and Etcher are not properly designed to write Windows ISO's
    • Etcher, in particular, even prompts a message about this
    • WinUSB, now called WoeUSB, despite being one recommended Linux solution to create USB drives with Windows ISOs on Linux, presented errors and didn't work for me
  3. Rufus was the software I used
  4. The chosen ISO was one that already worked for my coworkers before on other computers

Possible explanations:

At least one of the issues below was creating the problem:

  • bad pen drives (in this case, bad luck)
  • corrupted ISO (unreliable download provided by Microsoft's servers)
  • improper software to write the ISO to the USB, in particular, Linux USB writers not properly designed to write Windows ISOs
| improve this answer | |
1

OP's solution (TL;DR use Rufus) is the most fool-proof one. I'll attempt to explain what possibly went wrong.

Last decade most PCs have switched from BIOS to UEFIs (more details in this answer). UEFI uses a completely new boot process which is incompatible with the old one. It also supports booting from disks using new partitioning scheme called GPT (old one was MBR). Windows has an technical limitation that it requires disks to be GPT if you want to boot with UEFI, otherwise you have to use BIOS or enable CSM (Compatibility Support Module). All this makes preparing Windows installation flash drives tricky. Specifically, some methods of preparing one make it work only for UEFI or only for BIOS/CSM. (On a side note, Rufus intentionally uses these methods and forces you to choose only one boot mode to avoid accidentally installing Windows in a wrong mode.) If the flash drive was prepared for a different boot mode that currently used, this error message may appear.

The solution is to change boot mode or to prepare the flash drive for the mode you're using. Again, Rufus is your friend here.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.