2

I disabled browsing history from My Activity and deleted all elements; I made Chrome's History file read only; my browsing history from Clear browsing data shows "None" and I disabled history sync. Despite this, history is still saved: if I do a search, then that same search shows in my history (with a clock icon) when I type in the address bar, also if I close Chrome.

If I do Clear browsing data history doesn't appear anymore, but since history was marked as "None" something seems wrong.

How can I completely disable Chrome's history? Using incognito sessions wouldn't work, since that doesn't store logins, either.

System: Chrome 78.0.3904.97, Windows 10 1903 18362.418.

4
  • Did chrome make a new History file?
    – Moab
    Nov 6, 2019 at 17:43
  • No, I have just one History file, which is read only and doesn't contain any addresses from history.
    – Mauro
    Nov 6, 2019 at 19:50
  • You need to specify the Chrome version and your OS.
    – Ramhound
    Nov 6, 2019 at 22:02
  • Sorry, I completely overlooked that info; I'll edit the question: Chrome 78.0.3904.97, Windows 10 1903 18362.418.
    – Mauro
    Nov 6, 2019 at 23:28

3 Answers 3

1

Firstly, consider switching to Firefox, which allows you to turn off browsing history in its settings and has more concern for privacy overall.

Secondly, if you still prefer to use Chrome, you may want to configure your Chrome shortcuts to start the browser in incognito mode, because in this mode Chrome will not record your history. On Windows you can do the following.

  1. Navigate to the location of the shortcut:

    • Go to %USERPROFILE%\Desktop
      to find your desktop shortcut;
    • Go to C:\ProgramData\Microsoft\Windows\Start Menu\Programs
      to find the start menu shortcut;
    • Go to %AppData%\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar
      to find your taskbar shortcut;
    • Go to wherever you stash your browser shortcuts, if none of the above applies. :)
  2. Change the properties of the shortcut:

    • Open the properties and go to the Shortcut tab;
    • Edit the Target property: append -incognito to the end of the value,
      for example, in my case the value would look like as follows:
      "C:\Program Files (x86)\Google Chrome\Application\chrome.exe" -incognito;
    • Hit OK to save and close the properties.
  3. Test the shortcut:

    • Open Chrome by using your modified shortcut;
    • The profile button in the top right of Chrome should say Incognito.

Bonus: If you start Chrome with a text command rather than a shortcut,
just append -incognito to the end of the command to start it in incognito mode:

  • For example, Win + R; chrome -incognito; Enter.

Please note that this does NOT entirely prevent Chrome from working in normal mode, in which it does record your history, so be careful when you open new windows, for example:

  • Use the New incognito window option instead of New window;
  • Use the hotkey Ctrl + Shift + N to create a new incognito window,
    rather than Ctrl + N which would create a normal window.
0

Chrome, therefore Google keeps your history in their databases as well, you need to go to your google account. Find, "Manage your activity", then privacy, there you should see Web & App Activity and then you can disable it.

5
  • I did, in my "Web & App Activity" I have "Web & App Activity (paused)" and I have "Include Chrome history and activity from sites, apps, and devices that use Google services" unchecked. There is something else to do?
    – Mauro
    Nov 7, 2019 at 7:45
  • @Mauro How about in Chrome settings, Sync and Google Services tab, what does it look like?
    – siniradam
    Nov 13, 2019 at 2:47
  • In Settings I have History sync disabled; I'm not sure what do you mean by Google Services tab. Anyway I think I found the culprit, I'll post about it shortly.
    – Mauro
    Nov 13, 2019 at 8:21
  • There is a section called Sync & Google Services in Chrome settings. It says what to save. But I'm glad you figured out.
    – siniradam
    Nov 14, 2019 at 7:32
  • I think I disabled all that can be disabled there - it just seems Shortcuts can't be disabled from there (or I'm totally missing something). Thanks for the suggestion, though.
    – Mauro
    Nov 14, 2019 at 13:26
0

The last openend link are saved in the user profile directory, Shortcuts file; by resetting it and making it read only, when I open Chrome all the previously opened links are gone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.