0
AzCopy /Source:https://sourceaccount.blob.core.windows.net/mycontainer1
/Dest:https://destaccount.blob.core.windows.net/mycontainer2
/SourceKey:key1 /DestKey:key2 /S

After using this script to migrate data from one container to another it shows an error:

unknown command "/source:https://xxxxx.blob.core.windows.net/xxx" for "azcopy"

while the rest of the commands (copy, sync) are working fine.

1

Your command works fine on my end. Try to remove and reinstall AzCopy, because nothing is wrong with your command.

6
  • It still wont work. Shows the same error. – Amit Nov 7 '19 at 15:00
  • Did you try another device? Or try to run AzCopy ad administrator. – Erjen Rijnders Nov 7 '19 at 15:19
  • I tried on other devices as well, i think i am repeating same mistake everywhere. github.com/MicrosoftDocs/azure-docs/issues/42257 which version you are using ? – Amit Nov 8 '19 at 5:36
  • 8.1.0. Downloaded from the link I provided earlier. Is it solved? You said that the case can be closed on the github page. – Erjen Rijnders Nov 8 '19 at 7:32
  • Yes, its solved. They changed the syntax for the latest version(10.3.1). It will work in version 8 but not in 10.3. – Amit Nov 8 '19 at 9:19
1

The issue is Microsoft have created a totally new program with a completely different syntax and called it AzCopy. There's an old syntax and there's the AzCopy v10+ syntax.

0

Your AzCopy syntax is incorrect. Take a look at this link

Copy a container to another storage account

Syntax

azcopy copy 'https://<source-storage-account-name>.blob.core.windows.net/<container-name>?<SAS-token>' 'https://<destination-storage-account-name>.blob.core.windows.net/<container-name>' --recursive

Example

azcopy copy 'https://mysourceaccount.blob.core.windows.net/mycontainer?sv=2018-03-28&ss=bfqt&srt=sco&sp=rwdlacup&se=2019-07-04T05:30:08Z&st=2019-07-03T21:30:08Z&spr=https&sig=CAfhgnc9gdGktvB=ska7bAiqIddM845yiyFwdMH481QA8%3D' 'https://mydestinationaccount.blob.core.windows.net/mycontainer' --recursive
2
  • This works, but it's just a new feature of AzCopy and so not the right answer to Amit. – Erjen Rijnders Nov 7 '19 at 12:09
  • That's what i was thinking, the copy command and the command that i mentioned are different. – Amit Nov 8 '19 at 6:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.