1

I managed to screw something up and now Calculator on Windows 10 Pro won't open. It still shows up as an app when I search in the start menu, but is not listed under "Apps and features".

I've tried executing the following commands in an Admin PowerShell window, and I get the same error (further below).

Get-AppxPackage -allusers *windowscalculator* | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}
Add-AppxPackage -register "C:\Program Files\WindowsApps\Microsoft.WindowsCalculator_10.1812.10048.0_x64__8wekyb3d8bbwe\AppxManifest.xml" -DisableDevelopmentMode

This is the error I get with both commands:

Add-AppxPackage : Deployment failed with HRESULT: 0x80073CF3, Package failed updates, dependency or conflict
validation.
Windows cannot install package Microsoft.WindowsCalculator_10.1812.10048.0_x64__8wekyb3d8bbwe because this package
depends on a framework that could not be found. Provide the framework "Microsoft.UI.Xaml.2.0" published by
"CN=Microsoft Corporation, O=Microsoft Corporation, L=Redmond, S=Washington, C=US", with neutral or x64 processor
architecture and minimum version 2.1810.18003.0, along with this package to install. The frameworks with name
"Microsoft.UI.Xaml.2.0" currently installed are: {}
NOTE: For additional information, look for [ActivityId] df9e85bd-963e-0004-b295-9edf3e96d501 in the Event Log or use
the command line Get-AppPackageLog -ActivityID df9e85bd-963e-0004-b295-9edf3e96d501
At line:1 char:58
+ ...  | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.I ...
+                 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : WriteError: (C:\Program File...ppXManifest.xml:String) [Add-AppxPackage], IOException
    + FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand

I also tried installing .NET 4.8 and rebooting my PC, but that didn't work either. I still got the same error message.

I can't find any information on the Microsoft.UI.Xaml.2.0 framework that's stopping the installation of Calculator.

Where can I get the Microsoft.UI.Xaml.2.0 framework?

4
  • What actions exactly were you taking before the calculator application stopped working?
    – Ramhound
    Nov 8, 2019 at 15:13
  • @Ramhound unfortunately I don't know. I've spent the last few days rebuilding my computer after a nasty BSOD decided to cripple it. I was just getting around to doing some actual productive work when I discovered Calculator won't open.
    – CurtisHx
    Nov 8, 2019 at 15:26
  • Maybe you should try In-place Upgrade.
    – harrymc
    Nov 8, 2019 at 16:51
  • Get-AppxPackage Microsoft.UI.Xaml.2.0 returns something on my machine, you could try Get-AppxPackage -allusers Microsoft.UI.Xaml.2.0 | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"} to get it back and then run your first windowscalculator command again. it should work if this folder exists on your machine: C:\Program Files\WindowsApps\Microsoft.UI.Xaml.2.0_2.1810.18004.0_x64__8wekyb3d8bbwe
    – SimonS
    Nov 11, 2019 at 7:19

2 Answers 2

3

For anyone else who is looking for a solution to the similar issue and have stumbled upon this unanswered (atm) question because they googled that long PowerShell error message, here is the answer:

  1. Find Microsoft Calculator UWP app on MS Store
  2. Copy the calculator page URL
  3. Go to https://store.rg-adguard.net, select URL(Link) paste the link, click checkbox
  4. You will now get a full list of available downloads for Calculator app + dependencies
  5. Download latest version of Microsoft.WindowsCalculator_*.*.*.*_neutral, it should be at the very bottom
  6. Make sure you download both AppxBundle and BlockMap with the correct architecture (i.e. x64 for Windows x64)! Save them into the same directory/folder.
  7. Run the following command in PowerShell with Admin rights, using the actual filepath:
Add-AppxPackage path\\to\\the\\new_\*.\*.\*.\*_neutral___*.AppxBundle
  1. There will likely be unfulfilled dependency errors. The error message will tell you which version of the dependency you need to download.
  2. Repeat steps 6-8 until you're no longer getting dependency errors. The dependencies may be Appx not AppxBundle. That's fine. In the end, in your Downloads or whatever folder you will have something like:
Microsoft.UI.Xaml.2.4_2.42007.9001.0_x64__8wekyb3d8bbwe.Appx
Microsoft.UI.Xaml.2.4_2.42007.9001.0_x64__8wekyb3d8bbwe.BlockMap
Microsoft.VCLibs.140.00_14.0.29231.0_x64__8wekyb3d8bbwe.Appx
Microsoft.VCLibs.140.00_14.0.29231.0_x64__8wekyb3d8bbwe.BlockMap
Microsoft.WindowsCalculator_2020.2011.16.0_neutral___8wekyb3d8bbwe.AppxBundle
Microsoft.WindowsCalculator_2020.2011.16.70_neutral___8wekyb3d8bbwe.BlockMap
  1. Repeat step 7 for each AppxBundle, starting at the bottom of the dependency chain and working up until you're able to successfully install the main app.

If you still receive some weird error with typical MS-zero-context infor then make sure

  • Service AppX Deployment Service (AppXSVC) is up and running
  • Service Windows Modules Installer is up and running
  • Service Windows License Manager Service is up and running
  • Service Microsoft Store Install Service is up and running
  • You have enabled Developer Mode
0

For anyone looking for the command in 2022 to install to all users. Follow KreonZZ's steps then install in PowerShell with this:

DISM.EXE /Online /add-ProvisionedAppxPackage /PackagePath:.\Microsoft.MSPaint_5.1811.20017.0_neutral___8wekyb3d8bbwe.AppxBundle /dependencyPackagePath:.\Microsoft.UI.Xaml.2.0_2.1810.18004.0_x64__8wekyb3d8bbwe.Appx /dependencyPackagePath:.\Microsoft.VCLibs.140.00_14.0.30704.0_x64__8wekyb3d8bbwe.Appx /SkipLicense

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .