12

VLC Media Player 3.0.8 is taking a long time to launch on my Windows PC. It typically takes 6 seconds or more. I have a Win 10 machine with a class 50 SSD, Six Core Xeon 2.90GHz, etc. VLC launch should not be this slow.

How can I speed up the loading time of VLC?

1 Answer 1

36

There can be many causes for a slow launch in VLC 3, but here are two solutions I've confirmed help:

Solution A
VLCwin7User on the VideoLan forums came up a solution that I will paraphrase and add to:

  1. Bring up an administrative command prompt in the vlc.exe directory. This would typically be C:\Program Files (x86)\VideoLAN\VLC for 32-bit, or C:\Program Files\VideoLan\VLC for 64-bit.
    (To bring up an administrative prompt in this directory, open the Start menu and type cmd. Right click on Command Prompt and select Run as administrator. Then type cd, space, and then the VLC directory, and press enter.)

  2. Issue vlc-cache-gen .\plugins enter... which generates \plugins\plugins.dat

This brought launch time down to less than a second on my machine.


Solution B
This is the solution I had originally tried, but it only reduced the launch time by about 25%. I'm putting it here for completeness. I did not notice this making much difference after using Solution A from above.

  1. Open VLC preferences via the menu or by pressing CTRL+P.
  2. Select show settings > All from the bottom left corner
  3. In the Advanced section, uncheck "Scan for new plugins"

VLC launch time reduction setting

5
  • 2
    Thanks! I can confirm that pre-generating the plugins list noticably speeds startup, Nov 8, 2019 at 18:14
  • 1
    Thank you ! Solution A worked perfectly. The question is why is this thing not automated ? ... or why this phenomenon even exist ?
    – armen
    Aug 12, 2021 at 12:57
  • Thanks a bunch! Solution A worked for me!
    – Larphoid
    Dec 15, 2021 at 16:20
  • Thanks, this worked! Went from ~10 seconds to less then 1. Feb 11, 2022 at 13:46
  • Solution B worked for me and actually I was thinking that using VLC as portable is the source of this problem! Jan 1 at 0:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .