-1

puppet module install $module does not seem to work properly in Centos 7.

[root@client modules]# puppet module install spacepants-ds_389
Notice: Preparing to install into /etc/puppet/modules ...
Notice: Downloading from https://forgeapi.puppetlabs.com ...
Notice: Installing -- do not interrupt ...
/etc/puppet/modules
└─┬ spacepants-ds_389 (v1.1.7)
  ├─┬ puppetlabs-concat (v4.2.1)
  │ └── puppetlabs-stdlib (v4.25.1)
  └─┬ puppetlabs-inifile (v2.5.0)
    └── puppetlabs-translate (v1.2.0)

The module downloads just fine and seem to satisfy the required dependencies, but listing the result states the the dependencies are unmet:

[root@client modules]# puppet module list  --tree
Warning: Missing dependency 'puppetlabs-concat':
  'spacepants-ds_389' (v1.1.7) requires 'puppetlabs-concat' (>=4.0.0 <5.0.0)
Warning: Missing dependency 'puppetlabs-inifile':
  'spacepants-ds_389' (v1.1.7) requires 'puppetlabs-inifile' (>=1.0.0 <3.0.0)
Warning: Missing dependency 'puppetlabs-stdlib':
  'spacepants-ds_389' (v1.1.7) requires 'puppetlabs-stdlib' (>=4.2.0 <5.0.0)
/etc/puppet/modules
├─┬ spacepants-ds_389 (v1.1.7)
│ ├── UNMET DEPENDENCY puppetlabs-concat (>=4.0.0 <5.0.0)
│ ├── UNMET DEPENDENCY puppetlabs-inifile (>=1.0.0 <3.0.0)
│ └── UNMET DEPENDENCY puppetlabs-stdlib (>=4.2.0 <5.0.0)
├─┬ puppetlabs-inifile (v2.5.0)
│ └── puppetlabs-translate (v1.2.0)
└─┬ puppetlabs-concat (v4.2.1)
  └── puppetlabs-stdlib (v4.25.1)
/usr/share/puppet/modules (no modules installed)

Why is that?

puppetlabs-concat v4.2.1 >= 4.0.0
puppetlabs-inifile v2.5.0 >= 1.0.0
puppetlabs-stdlib v4.25.1 >= 4.2.0

Version numbers look OK to me.

| improve this question | | | | |
  • puppet --version gives 3.6.2 which is alot less than the Puppet >= 4.7.0 that the module requires. Might be the source of the problem. – azzid Nov 8 '19 at 20:19
0

Default version of puppet on centos 7 was the problem.

Installing the repo for puppet 5 and using it worked better:

# yum erase puppet
# rpm -Uvh https://yum.puppetlabs.com/puppet5-release-el-7.noarch.rpm
# yum install puppet

then all ok:

[root@client ~]# /opt/puppetlabs/bin/puppet module install spacepants-ds_389
Notice: Preparing to install into /etc/puppetlabs/code/environments/production/modules ...
Notice: Downloading from https://forgeapi.puppet.com ...
Notice: Installing -- do not interrupt ...
/etc/puppetlabs/code/environments/production/modules
└─┬ spacepants-ds_389 (v1.1.7)
  ├─┬ puppetlabs-concat (v4.2.1)
  │ └── puppetlabs-stdlib (v4.25.1)
  └─┬ puppetlabs-inifile (v2.5.0)
    └── puppetlabs-translate (v1.2.0)
[root@client ~]# /opt/puppetlabs/bin/puppet module list --tree
/etc/puppetlabs/code/environments/production/modules
└─┬ spacepants-ds_389 (v1.1.7)
  ├─┬ puppetlabs-concat (v4.2.1)
  │ └── puppetlabs-stdlib (v4.25.1)
  └─┬ puppetlabs-inifile (v2.5.0)
    └── puppetlabs-translate (v1.2.0)
/etc/puppetlabs/code/modules (no modules installed)
/opt/puppetlabs/puppet/modules (no modules installed)
| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.