1

Long post ahead, but hopefully these details are helpful.

Background

  • I have an HP 15-db0005dx notebook (specs here). By default, it came with Windows 10.
  • After about one year of ownership, I decided to migrate from Windows to Linux (Fedora 31 distro).
  • After successful installation, my Realtek wifi adapter wasn't working. I attempted installing any missing drivers, linux-headers, upgrades, updates, and build-essentials, but no change.
  • After all of this, I decided to reboot the computer.

The Problem

  • It now refuses to boot, giving a "Default Boot Device Missing or Boot Failed" message. (Good news, though--I've backed up all my important data.)

Details & What I've Tried

  • Upon receiving the error message, I hit OK. The Boot Manager displays, with the Boot Option Menu shown.
  • The Boot Option Menu instructs me to change/select options, Press F10 to BIOS Setup Operations, ESC to exit. But...there are no options.
  • I hit F10, and I receive a black screen with only the message "No bootable device -- Please restart system _"
  • Hitting enter produces the same message; so I shut it down, and restart after at least 15 seconds.
  • I repeat the above steps, this time with my live USB plugged in (note: I replaced Fedora 31 on the USB with Kali, as I wondered if Fedora was the problem)
  • The USB lights up when it is plugged in and the laptop is turned on; nothing different occurs than before.
  • I then restart the computer again.
  • Upon starting (with the USB plugged in), I hit F2 repeatedly until the HP PC Hardware Diagnostics UEFI appears. On this screen, I see the following: Version 1.21.0.0 - BIOS, For more information, please visit: www.hp.com/go/techcenter/PCDiags, Memory Test, Hard Drive Check, Language, Exit.
  • I go to HP's website, which I did not find helpful, but perhaps I missed something.
  • I tried the Hard Drive Check, both the quick and the extensive versions, both came back 100% ok. (Note: only 1 drive was available for checking)
  • I tried the Memory Test--again, it came back 100% ok.
  • I then restart the computer again.
  • Upon starting, I hit F10 repeatedly until the InsydeH2O Setup Utility is loaded.
  • In the System Log, I see error 03F0 listed; nothing special otherwise.
  • In Security, I've restored security settings to the factory defaults, with no change in behavior
  • In System Configuration, I've gone into the boot options, changed the boot order to allow USB diskette to boot first, and similarly with USB CD/DVD ROM Drive. I've also tried enabling Legacy Support, disabling Secure Boot, and Load HP Factory Default Keys. None of these resulted in any change in behavior.
  • I've also reseated my SSD, with no change in behavior.

Question

Before I use my laptop as a frisbee, can anyone help me figure out what I'm doing wrong, and how to get it to properly boot? I could take it to a repair shop, but I want to learn what's happening and why it's behaving this way.

Additional comments

  • Maybe something happened with the hard drive partitioning?
  • Whenever in one of the configuration menus, my laptop's fan is always on high.
  • 1
    Since the USB stick has been modified after the original install, have you used it in its current condition to successfully boot another computer? – Gypsy Spellweaver Nov 9 at 7:56
  • As a second option, if you have the USB stick to spare, is to create one for booting a different distro. One intended to be used, rather than tried-then-installed. My go-to for that purpose is Knoppix, with Gparted as a solid runner up. – Gypsy Spellweaver Nov 9 at 8:05
  • @GypsySpellweaver I just now used it in its current condition, and was able to successfully boot another computer with it. – d4rk_1nf1n1ty Nov 9 at 18:19
0

I am guessing that I deleted too much from my hard drive, and removed the partition used for recovery--though I'm not 100% sure if this is what happened or not.

What fixed this problem was downloading the Cloud Recovery tool from HP specifically for my laptop, and that got Windows running again. However, I still am trying to replace it with Kali Linux, so hopefully that goes better.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.