2

Recently, my Visual Studio Code just stopped working. I downloaded it using pacman -S code (code-1.40.0-1), way before, and haven't touched it ever since. I looked for other places, but can't figure out what's wrong with it. I can run electron4 all fine.

Whenever I try to run it:

$ code
electron4[41664]: ../../third_party/electron_node/src/node_file.cc:897:void node::fs::InternalModuleStat(const FunctionCallbackInfo<v8::Value> &): Assertion `args[0]->IsString()' failed.
 1: 0x562f06bab8a6  [electron4]
 2: 0x562f06baa72c  [electron4]
 3: 0x562f06bf8cc7  [electron4]
 4: 0x562f034488a1  [electron4]
 5: 0x562f03caf24e  [electron4]
fish: 'code' terminated by signal SIGABRT (Abort)

Edit: vscodium-bin from AUR is working as intended

0

It was a temporary bug caused by Arch moving from Electron 6 to 7, and VSCode not supporting 7 yet. A fix has been pushed to the repos, so just update and you're golden.

0

Same Issue here.
Downgraded as workaround until the issue is fixed.
sudo pacman -U /var/cache/pacman/pkg/code-1.39.2-1-x86_64.pkg.tar.xz

Can't comment: Yeah thank you:
It is fixed:
sudo pacman -S code

now brings Packages (2) electron6-6.1.1-1 code-1.40.0-2

  • it worked! so the package is broken then – buckle2000 Nov 9 at 9:32
0

This is already fixed at v1.40.0-2. Thanks for maintainers!

$ pacman -Syu

https://git.archlinux.org/svntogit/community.git/commit/trunk?h=packages/code&id=34ea20a2b94fed96b933f91b5cbd6094193af702

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.