41

Error Message:

/usr/bin/wg-quick: line 31: resolvconf: command not found

The issue:

I am not fully certain, I do have openresolv installed rn and have tried it and got the same response when resolvconf is installed.

Either way, I cannot connect to my VPN.

6 Answers 6

48

Modern Linux distributions use systemd, which comes with its own flavor of resolvconf as part of the resolvectl command. See manpage. A symlink called resolvconf can be created somewhere in $PATH.

  • On Arch linux there's the systemd-resolvconf package that does this for you.
  • On Debian (and Ubuntu?) you must do this manually. Using /usr/local to prevent possible package conflicts:
    ln -s /usr/bin/resolvectl /usr/local/bin/resolvconf
    

With the symlink in place, wg-quick works fine for me.

Edit: There is a Debian bug report requesting the symlink

1
  • 2
    I had to run the command systemctl enable systemd-resolved.service otherwise I got "Failed to set DNS configuration"
    – sam1370
    Sep 12, 2020 at 21:47
21

Had the same problem, found on this page: https://github.com/StreisandEffect/streisand/issues/1434

sudo apt install openresolv

Resolved it for me.

1
  • 2
    "Too few arguments"
    – sam1370
    Sep 12, 2020 at 21:47
7

Try using systemctl instead:

systemctl start wg-quick@<vpn-name>

Or if you wish to start the VPN every time you start your machine use:

systemctl enable wg-quick@<vpn-name>

1
  • 1
    This is not a solution for problem. Problem is because a question of "openresolve". Change metodh of start no change de problem. Mar 28 at 8:08
4

It’s not the solution, but if you comment out the DNS in the wg0 conf file it will work. wg-quick does a bunch of things behind the scenes, one of them is adjusting the nameserver, typically to use your vpn providers. Set your /etc/resolv.conf to use Cloudflare (1.1.1.1), then try again. It should connect without the resolvconf dependency.

1
  • no errors shown anymore, but networking is not working... May 12, 2021 at 11:04
3

just install it with apt-get install resolvconf and reboot, or comment out all DNS fields in configuration file

0

Seems like resolvconf command is missing in your system or it isn't installed, try this:

sudo apt install resolvconf
1
  • 1
    As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    Apr 30 at 5:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.