1

On macOS I have enabled "File Sharing" in the "Sharing" section of the "System Preferences" application. It says "File Sharing: On" and "Other users can access shared folders on this computer, and administrators all volumes, at smb://192.168.1.100".

Under "Options..." I have enabled "Share files and folders using SMB", and I have enabled "Windows Sharing" for my account.

One folder is listed under "Shared Folders": my account's "Public" folder. When selected, these users and permissions are listed under "Users":

  • Me: Read & Writer
  • Staff: Read Only
  • Everyone: Read Only

In the "Network" settings, under "WINS", the "NetBIOS Name" setting is set to "MACBOOKPRO-0A79" and the "Workgroup" settings is set to "WORKGROUP".

Finally, the "Firewall" under "Security & Privacy" is "Off".

(On Windows 10 Professional I can access the shared folder and volumes, by browsing to \\macbookpro-0a97, and entering credentials that match the credentials of my account on my Mac.)

On Windows 98 SE, when starting the computer, in the "Enter Network Password", I enter credentials that match the credentials of my account on my Mac. The "Network" configuration (found in the "Control Panel"), lists the following installed components (among others):

  • Client for Microsoft Networks
  • Intel 8255x-based PCI Ethernet Adapter (10/100)
  • TCP/IP (bound to the ethernet adapter)
  • File and printer sharing for Microsoft Networks

"TCP/IP" is configured to "obtain an IP address automatically", and the computer is connected physically to the same router that the Mac is connected to wirelessly. They are in the same subnet, and can ping each other.

For "File and printer sharing for Microsoft Networks", I have set "Browse Master" to "Enabled".

Under the "Identification" tab of the "Network" configuration, the "Workgroup" setting is set to "WORKGROUP".

Typing net view on the "MS-DOS Prompt" gives the following output:

Servers available in workgroup WORKGROUP
Server name            Remark
----------------------------------------
\\INTELLISTATION       IBM IntelliStation E Pro 6893-810
\\MACBOOKPRO-0A79      Michiel's MacBook Pro
The command was completed successfully.

The Mac is visible in the "Network Neighbourhood", but when I double-click it, I get the following error:

\Macbookpro-0a97 is not accessible. The computer or share name could not be found. Make sure you typed it correctly, and try again.

Also, when I use the "Find: Computer" option from the Start menu ("Start", "Find", "Computer...") and I type "MacBookPro-0a79" in the "Named:" field, the following record is displayed:

  • Name: MacBook Pro-0a79
  • Location: Network Neighbourhood
  • Comment: Michiel's MacBook Pro

Double-clicking this record gives the exact same error as double-clicking the computer in Network Neighbourhood.

Right-clicking it and selecting "Properties", gives the following warning:

The server \Macbookpro-0a97 could not be found on the network.

After that, the properties applet opens, but it shows no meaningful information.

How can I actually access data on the Mac from Windows 98 SE?

1

The security methods of Windows 98 (SMBv1 only, Master browsing to list all devices) have been displaced by more secure methods. Windows 98 cannot be secured (basically a DOS system with a GUI attached to it) and so you will not be able to connect it to any modern system.

| improve this answer | |
0

According this forum post, Samba on Windows 98 will automatically send your login username as the username to connect to the network. Have you tried renaming the Windows 98 SE account to match the username on your MacOS?

| improve this answer | |
  • Indeed, my Windows 98 SE "Microsoft Network" account uses credentials that match my account on the Mac. – Michiel van Oosterhout Nov 10 '19 at 15:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.