0

I used the Data Migration tool by Samsung to clone the content (Windows boot drive) of a Samsung SSD 850 Pro to a Samsung SSD 950 Pro. But I can't boot from it now.

Motherboard: GA-Z170X-Gaming-7 with F8 Bios version
Windows 10 Pro (1803)
Bios mode is UEFI
Drive partition is GPT

If I select the 950 Pro as boot device I get the following message

Reboot and Select proper Boot device
or Insert Boot Media in selected Boot device and press a key

If I look into Diskmgmt.msc the drive is offline with the following message:

This disk is offline, because it has a signature collision with another disk that is online.

I tried to unplug the old drive (850 Pro), but I still can't boot from the new SSD. Installing the Samsung NVME driver also didn't changed something. The device is still using the Intel driver. Samsung Magician can't correctly detect the device (sure, it's offline). I can set it to online mode to access the data, but I can't boot correctly from it.

It seems the boot sector is faulty. Do I have to reinstall Windows completely or can I get the cloned drive to work?

1
  • 1
    Base on the signature collision, I think yes you must reinstall Windows – John Nov 10 '19 at 23:35
0

Now I fixed it myself. I believe the main reason was that after the clone process the PC booted with two bootable disks, which had the same id in the GPT (through the clone tool). These were the steps I did to get it running:

  • delete partition of the new drive with diskpart
  • clone the drive
  • shutdown of the pc and unplug of the old drive
  • reboot and have fun

Here are the commands for diskpart:

  • enter diskpart in a new command line (cmd)
  • list disk
  • select disk x
  • list partition
  • select partition x
  • delete partition

I think you could also set a new unique id with diskpart instead of the above (or afterwards). Here are the commands again:

  • enter diskpart in a new command line (cmd)
  • list disk
  • select disk x
  • uniqueid disk to see the current id
  • set a new id with uniqueid disk ID=xxx (take old one and modify it a bit)
4
  • There’s no MBR if it’s GPT. ;) From the question, it sounds to me like you were accidentally trying to BIOS-boot when UEFI-booting was required. – Daniel B Nov 17 '19 at 15:55
  • @DanielB: Thanks for the correction. How do I see the difference? In the settings Bios mode was UEFI. – testing Nov 17 '19 at 16:14
  • Depends on the firmware. I’ve seen boot selection menus that had “UEFI:” in front of the UEFI list entries and nothing in front of the legacy (CSM) entries. – Daniel B Nov 17 '19 at 18:29
  • I didn't change a setting in the BIOS. The new drive was immediadetly available as Windows Boot Manager (Samsung SSD 950 Pro) in the boot sequence as default. – testing Nov 18 '19 at 8:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.