0

We have been upgrading Windows 10 1803 on multiple computers to 1903, but the problem is that Edge doesn't work after the upgrade.

We have tried sfc /scannow, dism /cleanup-image, repairing Edge, resetting Edge, re-installing edge using the powershell script below:

Get-AppXPackage -AllUsers -Name Microsoft.MicrosoftEdge | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml” -Verbose}

The error below is reported in Event Viewer:

Faulting application name: MicrosoftEdge.exe, version: 11.0.18362.418, time stamp: 0x5d995b38 Faulting module name: EMODEL.dll, version: 11.0.18362.418, time stamp: 0x5d9957cb Exception code: 0xc0000409 Fault offset: 0x0000000000120fa3 Faulting process id: 0x2088 Faulting application start time: 0x01d59a04e44f894d Faulting application path: C:\Windows\SystemApps\Microsoft.MicrosoftEdge_8wekyb3d8bbwe\MicrosoftEdge.exe Faulting module path: C:\Windows\SystemApps\Microsoft.MicrosoftEdge_8wekyb3d8bbwe\EMODEL.dll Report Id: 8fd8de85-54d1-4d1a-8b7b-a39a94c21091 Faulting package full name: Microsoft.MicrosoftEdge_44.18362.387.0_neutral__8wekyb3d8bbwe Faulting package-relative application ID: MicrosoftEdge

Update:

I aplogise as the event log info was not from the problem computer, I have since updated it.

I have checked the version on the computer with the upgrade of 1803 to 1903 and can confirm that the version is the same as on a computer with 1903 which has Edge installed and working. The working copy I am comparing against is a system which has had 1903 installed from image, not upgrade. It is when upgrading that we get the issue.

6
  • 1
    "11.0.10240.16384" - This is an indication the version of Edge that is installed is the same version that was installed on Windows 10 version 1507. That version of Edge is not compatible with 1903. Based on the context of deploying 1903 to multiple computers, it sounds like you are in a corporate environment, you should contact your IT department for assistance in this matter. What edition of Windows are you running? Instead of replying to this comment with a comment, provide any information, as an edit to your question.
    – Ramhound
    Nov 12, 2019 at 17:33
  • You have Windows 10 V1803 running now and so Edge should be that version unless you changed something. On one machine do a a Windows 10 Repair Install to V1903 and that should correct Edge
    – John
    Nov 12, 2019 at 17:44
  • 1
    Please be aware that Edge is being replaced with a Chromium-based Edge in the future, so that your company should move away from the Spartan-based version ASAP. In the future you won't be able to rely on IE or Spartan-based Edge at all, so find all users and workflows who still use it, Nov 12, 2019 at 20:02
  • Chromium based Edge is still not in production release so you should wait until it is in production. Otherwise, standard Edge works fine in V1903 and as of 2 or 3 hours ago V1909. Works very well.
    – John
    Nov 13, 2019 at 0:30
  • I apologize as the event log that I posted was not from the problem computer, I have now updated the message. I can confirm that the version of Edge is the same as another computer running 1903 with a working copy of Edge. I will explain in the main text. Nov 13, 2019 at 9:36

1 Answer 1

0

I had the same problem tried also to reinstall edge via different versions of powershell scripts, though my windows profile is broken so I tested it via new user with the same result. The final cause was Comodo antivirus, even it was switch off and used only ocasionaly while other installed McAfee was not in use only full uninstall did the job.

1
  • We don't have Comodo AV, but we have Panda. It's so long ago now that I don't know if this issue is even relevant to us. I think we just worked around it by using Chrome. Apr 24, 2020 at 13:10

Not the answer you're looking for? Browse other questions tagged or ask your own question.