0

our Windows Server 2012 Essentials is getting evenvwr poluted with the error message bellow and attached every 30 seconds. I've done a lot of research but nothing worked so far, this is what I tried:

  • Check the NETWORK SERVICE permissions on C:\Windows\System32\Tasks\Microsoft\Windows (it has FULL CONTROL)

  • checked services and its dependencies and ensure they are running and have startup mode = automatic

  • checked windows license with slmgr /ato

  • started and stopped sppsvc service with net stop sppsvc/ net start sppsvc

This is our domain controler so I can't reinstall Windows - Any help please?

Log Name: Application

Source: Microsoft-Windows-Security-SPP

Date: 11/12/2019 1:07:58 PM

Event ID: 16385

Task Category: None

Level: Error

Keywords: Classic

User: N/A

Computer: DC20001811

Description:

Failed to schedule Software Protection service for re-start at 2119-10- 19T18:07:58Z. Error Code: 0x80041316.

Event Xml:

Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event":

System:

 Provider Name="Microsoft-Windows-Security-SPP" Guid="{E23B33B0-C8C9-472C-A5F9-F2BDFEA0F156}" EventSourceName="Software Protection Platform Service" : 

 EventID Qualifiers="49152": 16385 EventID: 

 Version: 0 Version: 

 Level: 2 Level: 

 Task: 0 Task: 

 Opcode: 0 Opcode: 

 Keywords: 0x80000000000000 Keywords: 

 TimeCreated SystemTime="2019-11-12T18:07:58.000000000Z" : 

 EventRecordID: 4441021 EventRecordID: 

 Correlation : 

 Execution ProcessID="0" ThreadID="0" : 

 Channel: Application Channel: 

 Computer: Andromeda.snapd.local Computer: 

 Security : 

System:

EventData:

 Data: 0x80041316 Data: 

 Data: 2119-10-19T18:07:58Z Data: 

EventData:

Event:

enter image description here

NETWORK SERVICE account has Read permissions

Service is set to use the NETWORK SERVICE account 2

Service is set to use the NETWORK SERVICE account

Task Scheduler service is running

  • Please clarify your specific problem or add additional details to highlight exactly what you need. – Ramhound Nov 12 '19 at 21:31
  • Hi Ramhound, the problem is that the eventvwr is getting this error every 30 seconds and, after researching a lot and trying a couple of different things, I couldn't get this resolved. What I need is a help to identify the root cause of this error and resolve it. – Tiago Nov 13 '19 at 15:10
  • Provide the relevant information (screenshot) for each potential resolution described here. While you have specified you verified the permissions on a folder, it's not clear, if you verified the permissions on the folder specified in the support article for this problem. This error being generated, is specifically connected to a permission problem, on a folder surrounding the task scheduler. – Ramhound Nov 13 '19 at 15:32
  • Hi Ramhound, thanks a million for the help, I couldn't find how to attach the images here in the comment session, so I added to the original question. I hope this helps, thanks again. – Tiago Nov 13 '19 at 16:06
0

This series of steps worked for me. It is an abbreviated version of this solution.

  1. Back up all files in the directory C:\Windows\System32\Tasks\Microsoft\Windows\SoftwareProtectionPlatform just in case
  2. Add an XML extension to the files in the SoftwareProtectionPlatform folder
  3. Navigate to to Computer Management->System Tools->Task Scheduler->Task Scheduler Library->Microsoft->Windows->SoftwareProtectionPlatform
  4. Right-click on each task and select Delete
  5. Right-click on SoftwareProtectionPlatform, Import Task, and import each of the files that you renamed. Don't worry if they don't appear in the Task List.
  6. Navigate to Computer Management->Services and Applications->Services and restart the Software Protection service
  7. Check the Event Viewer to verify that the errors have stopped
  8. Delete the XML files in the SoftwareProtectionPlatform folder
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.