3

Every time I open an existing document in Word 2016 on Windows 10 I get this error:

Word could not create the work file. Check the temp environment variable.

I can edit the document fine, and save it, but I have an error message popped up in the background and it makes an annoying ding every time I open a document.

If I open Word and create a new document I can save it fine, but the next time I open it, the error appears.

Articles found in searches often suggest to use to check the Cache environment variable is correct - mine is %USERPROFILE%\AppData\Local\Microsoft\Windows\INetCache which according to these articles is correct).

I have also noticed that the location above is set to read-only in Windows, which doesn't seem right, but I don't know if this is normal or the cause of my problem.

Has anyone resolved this error recently?

5
  • Many of the articles that a search is returning relate to earlier versions of Windows and Office and read like they have been written by a bot so I'm not that confident in them. However answers.microsoft.com/en-us/msoffice/forum/… is helpful and more recent (and clearly many other people are having the same problem). Annoyingly Microsoft have recently locked the article, so it isn't clear if a fix will appear there. – dunxd Nov 14 '19 at 11:01
  • Microsoft added a security featured called Controlled folder access as part of Windows Defender at some point this year. It's designed to stop ransomware. I see a lot of blocked actions in the logs for this. I'm going to turn it off and see if it helps. – dunxd Nov 14 '19 at 11:39
  • Tempfolders are not included into protected folders list of default Controlled folder access settings... – Akina Nov 14 '19 at 11:47
  • That was a red-herring. Controlled folder access had done some annoying things like prevent me from saving files from Notepad and screenshots to my desktop (PickerHost.exe isn't trusted) but turning it off completely did not stop the error from Word. – dunxd Nov 14 '19 at 12:02
  • I rejected the edit that changed the registry value from what is actually set on my computer (and presumably is Microsoft's default setting) to the valid, but less commonly known %localappdata% variable. – dunxd Nov 15 '19 at 16:19
2

In my case this error message popped up from the Word Preview just by selecting the file in Windows Explorer. I suspect this is the same for your case because you write "message popped up in the background". I could fix this by deleting the following Registry Keys:

Word Preview : HKCR\CLSID\{84F66100-FF7C-4fb4-B0C0-02CD7FB668FE}
PowerPoint Preview : HKCR\CLSID\{65235197-874B-4A07-BDC5-E65EA825B718}
Excel Preview : HKCR\CLSID\{00020827-0000-0000-C000-000000000046}

According to Microsoft this happens when the 64bit Office is installed first, then uninstalled and then the 32bit Office is installed. But I doubt that I ever installed the 64bit Office.

See also: https://docs.microsoft.com/en-us/office/troubleshoot/error-messages/no-file-previews-file-explorer-switching-to-32-bit

1
  • That was exactly it. A bug in Windows Explorer file preview. Once I disabled that the problem went away. Nasty bug in Windows and Office. I may have installed 64-bit Windows. Why wouldn't I? Windows is 64-bit. Latest version of macOS doesn't even support 32-bit apps anymore. Is it too much to ask the MS make the 64 bit reliable enough for mainstream use? – dunxd Apr 17 '20 at 9:01
1
  • Close all MS Word windows.
  • Open Explorer.
  • Enable "View" - "Show hidden files".
  • Navigate C:\Users\%USERNAME%\AppData\Local\Microsoft\Windows\INetCache.
  • Create Content.Word sub-folder. If it exists, delete and re-create it.

for more information, see "Word could not create the work file" error message when you save a document in Microsoft Word

7
  • I've tried this - it makes no difference. Something else is causing the problem. – dunxd Nov 14 '19 at 11:38
  • Open CMD window, execute set temp - it must show C:\Users\current_user_name\AppData\Local\Temp. Check tmp (must be the same) and localappdata (must be C:\Users\current_user_name\AppData\Local). – Akina Nov 14 '19 at 11:42
  • All those are showing the locations as you say. – dunxd Nov 14 '19 at 11:45
  • @dunxd You may try to investigate what file/folder creation fails by starting Word under ProcessMonitor... – Akina Nov 14 '19 at 11:52
  • Apologies - I deleted the Content.Word folder from INetCache, and then started Word, which recreated the folder. Now the problem seems to have gone away. I will now test for a couple of days, and if the problem really has gone, I'll return and mark this as accepted. Thanks! – dunxd Nov 14 '19 at 12:00
0

Some users, like myself, have seen this problem disappear when disabling the preview pane on file explorer... Some says that this preview pane incompatibility can come from office 32bits on windows 64bits.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.