0

In my anaconda environment I can't use pip anymore

(roo_env) (base) C:\Users\antoi\Documents\Programming\roomfinder>pip install csvkit
Traceback (most recent call last):
  File "C:\ProgramData\Anaconda3\Scripts\pip-script.py", line 6, in <module>
    from pip._internal.main import main
ModuleNotFoundError: No module named 'pip._internal.main'

(roo_env) (base) C:\Users\antoi\Documents\Programming\roomfinder>python3 -m pip --version

(roo_env) (base) C:\Users\antoi\Documents\Programming\roomfinder>pip3 --version
'pip3' is not recognized as an internal or external command,
operable program or batch file.

(roo_env) (base) C:\Users\antoi\Documents\Programming\roomfinder>pip3 --version
'pip3' is not recognized as an internal or external command,
operable program or batch file.

(roo_env) (base) C:\Users\antoi\Documents\Programming\roomfinder>pip --version
Traceback (most recent call last):
  File "C:\ProgramData\Anaconda3\Scripts\pip-script.py", line 6, in <module>
    from pip._internal.main import main
ModuleNotFoundError: No module named 'pip._internal.main'

I don't know if it is a problem with my environment variables. Here is my path:

C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\iCLS\;C:\Program Files\Intel\Intel(R) Management Engine Components\iCLS\;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Windows\System32\OpenSSH\;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\Program Files\Intel\WiFi\bin\;C:\Program Files\Common Files\Intel\WirelessCommon\;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0\;%SYSTEMROOT%\System32\OpenSSH\;C:\Program Files\Git\cmd;C:\Program Files\nodejs\;C:\Program Files (x86)\Microsoft SQL Server\Client SDK\ODBC\110\Tools\Binn\;C:\Program Files (x86)\Microsoft SQL Server\150\DTS\Binn\;C:\Program Files\Microsoft SQL Server\Client SDK\ODBC\170\Tools\Binn\;C:\Program Files (x86)\Microsoft SQL Server\150\Tools\Binn\;C:\Program Files\Microsoft SQL Server\150\Tools\Binn\;C:\Program Files\Microsoft SQL Server\150\DTS\Binn\
  • If you run conda list, what is the output? Could you add that to the question? – Randomhero Nov 14 '19 at 15:27
  • Also just to note, it looks like you have both a virtualenv as well as a conda environment activated. Could you try to deactivate them both (using deactivate for virtualenv and conda deactivate for conda. Then only make sure that the conda environment is activated. – Randomhero Nov 14 '19 at 15:29
  • @Randomhero the (base) one? Sure! Still gives the same – Revolucion for Monica Nov 14 '19 at 16:52
  • Hmm ok. Could you post the output of conda list? – Randomhero Nov 18 '19 at 9:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.