1

I have the following problem on my computer:

Every time I connect a USB memory stick to my computer it is assigned a drive letter, and this does not go away when I disconnect the memory stick. You can see below that my File Explorer shows a large number of entries for USB memory sticks that are no longer connected to the computer.

How do I make these go away?

https://i.stack.imgur.com/9NnhE.jpg

2
1

I assume it is a drive letter issue in Windows 10.

There is a similar post on the microsoft forum.

Solution:

  1. Right Click each non-existent drive one at a time and select Properties.

  2. When the Properties opened there are the General, DVD Region, Volumes, Driver, Details and Events tabs. Click the Driver tab and then select Disable. After selecting Disable the "are you certain you want to do this" dialog appears and on this screen I selected Yes.

After performing the above the entire problem was resolved. Then when inserting random Jump Drives the USB Drive letter populated. Remove the Jump Drive and the Drive is no longer present in both File Explorer and Disk Management.

0
0

You could try using the Windows Disk Management Tool

Do this by hitting Start, typing "partition" into the search box, then choosing "Create and format hard disk partitions"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.