0

After upgrading a win7 host to win10, how do I make its DNS lookups work again?

Unchanged for this host is its static IPv4 address, subnet mask, default gateway, and hardcoded university campus DNS server (whose IP address hasn't changed in years). IPv6 disabled.

Under "advanced TCP/IP settings," tab "DNS," checkbox "Append primary and connection specific DNS suffixes." DNS suffix: campus.edu, where the host is myhostname.campus.edu.

Evidence that DNS is broken but connectivity works: from a DOS prompt, ping anotherhost.campus.edu fails, but ping anotherhost and ping 123.234.123.234 to that host's dotted quad work. The same for viewing a webpage served by anotherhost: dotted quad and unqualified hostname show the webpage, but anotherhost.campus.edu fails "Can't reach this page."

nslookup www.google.com (or any hostname at all, qualified or not, valid or garbage) times out with "Server UnKnown."

ipconfig /all confirms all the names and dotted quads that I typed into Control Panel.

4
  • Are you running a local DNS server? nvm just saw you were, We had an issue similar in the past. Our local domain is the same as our off site website. We would get a resolution error when trying to get to our page from on our network. I had to add a redirect in IIS. Also some subdomains I would still have to add an (a) record in the dns server to redirect.
    – Vdub
    Nov 14, 2019 at 23:48
  • Campus IT would protest loudly if I dared to run my own DNS server! Nov 14, 2019 at 23:56
  • @CamilleGoudeseune - Can you try using one of the third-party DNS providers like OpenDNS, Google, Cloudflare?
    – Ramhound
    Nov 15, 2019 at 0:02
  • Done. In control panel, DNS, removed campus's, added 8.8.8.8 and secondary 1.1.1.1. Confirmed with ipconfig. No change to the symptoms. Then I changed the numbers to garbage. Now the web browser fails faster, if you can call that progress. Deleting the numbers completely, still the same symptoms. Hmm. Nov 15, 2019 at 0:08

2 Answers 2

0

I only see two potential solutions.

1. Set DNS to automatic
or
2. Use an HTTP proxy and force DNS queries through said proxy (An OpenVPN connection may also work, basically anything that tunnels DNS queries to be handled by a different host)

2
  • Automatic DNS requires DHCP, but I'm using a static IP address instead. Nov 15, 2019 at 18:26
  • @CamilleGoudeseune Then you could try setting the DNS servers to the IP address of the gateway.
    – Ecstasy
    Nov 15, 2019 at 19:18
0

The gateway was incorrect. Because the host was on a 500-address network, xxx.xxx.216.1 was correct, despite the host's IP being xxx.xxx.217.yyy. Correcting that restored DNS, by restoring access to the DNS server.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .