2

I'm trying to make WOL work between 2 computers in the same local network, but it currently does not work.

In order to debug the situation and avoid potential problems with the router discarding the WOL "magic packets", I'd like to temporarily test a direct ethernet cable connection between:

  • Computer A running Windows 7
  • Computer B off, to be waked

Since Computer B is off, it has no IP. (Even adding DHCPd server on Computer A wouldn't change anything about this).

I did this configuration on Computer A's ethernet card settings (I chose 192.168.2.1 because 192.168.1.1 is already taken by the other network card: WiFi)

enter image description here

I then tried this on Computer A but it doesn't work:

enter image description here

Questions:

1) Since Computer B is off, it has no IP, which IP should I fill in Computer A's "WakeOnLan Magic Packet" tool?

2) More generally, how to make WakeOnLan work with a direct ethernet cable connection (without any router; as said previously I want to do this to debug WOL)?


Note: I've tried:

  • WakeOnLanGui.exe > Send Options > Local Subnet => nothing received on Computer B,

  • WakeOnLanGui.exe > Send Options > Internet => packet received on Computer B, as seen with sudo tcpdump on Computer B

  • You have to send it from an IP address in the local network that B would be in if it was on ... – DavidPostill Nov 17 '19 at 20:54
  • @DavidPostill in the screenshot, you have to add a destination IP, not a source IP... But since computer B is off, it has no IP. Also it's really a direct ethernet cable connection between A and B. No router involved for this test. – Basj Nov 17 '19 at 20:57
  • 1
    Does computer B even support WOL? "Powered-down or turned off computers capable of Wake-on-LAN will contain network devices able to "listen" to incoming packets in low-power mode while the system is powered down. " – DavidPostill Nov 17 '19 at 21:03
  • @DavidPostill Yes, the MB manual says: "Power On by PME" [Enabled] Allows you to turn on the system through a PCI/PCIE/onboard LAN device. (Disabled: Disables the PME to wake up from S5 by PCI/PCIE/onboard LAN devices) – Basj Nov 17 '19 at 21:06
  • Check the basics first. This would require a crossover cable if at least one of the computers does not support Gigabit Ethernet (meaning that it has auto-MDIX support). Can you confirm that one of the computers' NICs supports Gigabit? It's worth quickly confirming that you can ping one PC from the other, to be 100% sure they can communicate. – Mr Ethernet Nov 17 '19 at 21:12
1

The problem came from my motherboard (defective onboard LAN) + PCI Ethernet card.

The conclusion can be found in Is it normal that the LEDs of the network adapter are off when the computer is off and you want to power it with WakeOnLan?.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.