1

Every time I would try to enable Hyper-V, it fails with this error in CBS.log :

2019-11-19 12:34:20, Info                  CBS    Exec: Resolving Package: HyperV-UX-PowerShell-Module-HyperV-WOW64-servercommon-Package~31bf3856ad364e35~amd64~ja-JP~10.0.17763.1, Update: acc2e8a20c76ffe3547579459bc35e3a, PinDeployment: amd64_hyperv-ux-powershel..oyment-languagepack_31bf3856ad364e35_10.0.17763.1_ja-jp_759d6514b48b8eca
2019-11-19 12:34:20, Info                  CBS    Exec: 84 deployments need bulk staging
2019-11-19 12:34:20, Error                 CSI    000067a7@2019/11/19:11:34:20.604 (F) onecore\base\wcp\componentstore\csd_locking.cpp(95): Error STATUS_SXS_ASSEMBLY_MISSING originated in function CCSDirectTransaction::LockComponent expression: (null)[gle=0x80004005]
2019-11-19 12:34:20, Error                 CSI    000067a8 (F) STATUS_SXS_ASSEMBLY_MISSING #50936360# from CCSDirectTransaction::OperateEnding at index 0 of 1 operations, disposition 2[gle=0xd015000c]
2019-11-19 12:34:20, Error                 CSI    000067a9 (F) HRESULT_FROM_WIN32(ERROR_SXS_ASSEMBLY_MISSING) #50936202# from Windows::ServicingAPI::CCSITransaction::ICSITransaction_PinDeployment(Flags = 0, a = HyperV-UX-PowerShell-Module-HyperV-vm-Deployment-LanguagePack, version 10.0.17763.1, arch amd64, culture [l:5]'ja-JP', nonSxS, pkt {l:8 b:31bf3856ad364e35}, cb = (null), s = (null), rid = 'HyperV-UX-PowerShell-Module-HyperV-vm-Package~31bf3856ad364e35~amd64~ja-JP~10.0.17763.1.882ec3c0a4ad38131b14954a45d63426', rah = (null), manpath = (null), catpat[gle=0x80073701]
2019-11-19 12:34:20, Error                 CSI    h = (null), ed = 0, disp = 0)[gle=0x80073701]

I'd guess it's the Japanese language installed on my system that produces this error... but I can't uninstall it. Every time I run lpksetup /u and try to disinstall Japanese, it ends up with a "Failed to Uninstall". Again my CBS.log looks like this :

2019-11-19 12:39:07, Info                  CSI    e35}]) ref: ( flgs: 00000000 guid: {d16d444c-56d8-11d5-882d-0080c847b195} name: [l:79]'Package_2_for_KB4486167~31bf3856ad364e35~amd64~~10.0.1.2752.4486167-538_neutral' ncdata: [l:0]'')
  (1684)  MarkUnstaged: flags: 0 tlc: [018e321f53db726f5b2fb527205ef28b, version 4.0.15744.161, arch amd64, nonSxS, pkt {l:8 b:31bf3856ad364e35}]) ref: ( flgs: 00000000 guid: {d16d444c-56d8-11d5-882d-0080c847b195} name: [l:79]'Package_2_for_KB4486167~31bf3856ad364e35~amd64~~10.0.1.2752.4486167-538_neutral' ncdata: [l:0]'')
  (1685)  Unpin: flags: 0 tlc: [018e321f53db726f5b2fb527205ef28b, version 4.0.15744.161, arch amd64, nonSxS, pkt {l:8 b:31bf3856ad364e35}]) ref: ( flgs: 00000000 guid: {d16d444c-56d8-11d5-882d-0080c847b195} name: [l:79]'Package_2_for_KB4486167~31bf3856ad364e35~amd64~~10.0.1.2752.4486167-538_neutral' ncdata: [l:0]'')
2019-11-19 12:39:07, Error                 CSI    000067b1 (F) The TLC was not marked by this installer[gle=0x80004005]
2019-11-19 12:39:07, Error                 CSI    000067b2@2019/11/19:11:39:07.726 (F) onecore\base\wcp\componentstore\csd_pin.cpp(624): Error STATUS_SXS_ASSEMBLY_NOT_FOUND originated in function CCSDirectTransaction::MarkTlcUnstaged expression: (null)
[gle=0x80004005]
2019-11-19 12:39:07, Error                 CSI    000067b3 (F) STATUS_SXS_ASSEMBLY_NOT_FOUND #51154315# from CCSDirectTransaction::OperateEnding at index 1 of 1686 operations, disposition 2[gle=0xd0150004]
2019-11-19 12:39:07, Error                 CSI    000067b4 (F) HRESULT_FROM_WIN32(ERROR_SXS_ASSEMBLY_NOT_FOUND) #51154111# from Windows::COM::CComponentStore::InternalTransact(...)[gle=0x800736b3]
2019-11-19 12:39:07, Error                 CSI    000067b5 (F) HRESULT_FROM_WIN32(ERROR_SXS_ASSEMBLY_NOT_FOUND) #51154109# from Windows::ServicingAPI::CCSITransaction::ICSITransaction_Commit(Flags = 102, pSink = NULL, disp = 0)[gle=0x800736b3]
2019-11-19 12:39:07, Error                 CSI    000067b6 (F) HRESULT_FROM_WIN32(ERROR_SXS_ASSEMBLY_NOT_FOUND) #51154108# 41041 us from Windows::ServicingAPI::CCSITransaction_ICSITransaction::Commit(flags = 0x00000066, pSink = NULL, disp = 0)
[gle=0x800736b3]

I tried many, many things to get it done but nothing worked :

  • DISM /Online /Cleanup-Image /ScanHealth
  • DISM /Online /Cleanup-Image /RestoreHealth
  • sfc /scannow
  • Deleting registry key for the language
  • Reinstalling Japanese
  • Deleting packages one by one (by the way some of them tells me "Access Refused", while others tell me "Assembly not found")

PS: My computer is compatible with Hyper-V. Virtualization is enabled.

  • Are you trying these from an elevated/admin powershell? – Smock Nov 19 '19 at 14:01
0

Error 0x80073701 is ERROR_SXS_ASSEMBLY_MISSING. It means that some system files are missing, causing Windows changes to fail.

Perhaps the best way to return these missing files is to effect an In-place Upgrade, upgrading Windows to itself, using the latest Windows version in an offline installation.

For details see the article Repair Install of Windows 10 with an In-place Upgrade.

  • This worked, I can't give a +1 but I wish I could. For the instance, I found out I had a blocked windows update. Doing the In-place Upgrade worked like a charm. – Gabriel Bouillon Nov 19 '19 at 17:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.