1

I used to cycle between three keyboard settings:

  • QWERTY
  • French AZERTY
  • Belgian AZERTY

I removed French AZERTY from the list, but since then, whenever I boot Windows I get contradicting information.

The keyboard layout popup screen (Win + Space) and the language bar (in the taskbar) both me I have the two AZERTYs available, but the language settings window tells me that I have the Belgian AZERTY and QWERTY (which is what I want):

enter image description here

The only way I can solve this is to remove the QWERTY entry, and then add it again. This adds the QWERTY option but it still doesn't remove the French AZERTY option:

enter image description here

This seems to fix the popup screen and the language bar (well, partially), but when I reboot I have to do it all over again.

How do I get Windows 10 to actually give me the keyboard layouts that I've configured, instead of some presumably cached version?


To pre-empt a possible comment, I only have one language (and thus keyboard layout list), this isn't a confusion with using the wrong group:

enter image description here

5
  • 1
    Perhaps this answer can help.
    – harrymc
    Nov 19, 2019 at 14:43
  • @harrymc: It didn't fully resolve the issue, but it did lead me to an acceptable enough solution. Note that I needed to change the CURRENT_USER registry settings too, not the just .DEFAULT. Also, now my language changes when I move to Belgian AZERTY (which I don't want). But if you post an answer I will accept it.
    – Flater
    Nov 19, 2019 at 15:46
  • I can't copy that answer here - the moderators would prefer that I close this post as duplicate of the other.
    – harrymc
    Nov 19, 2019 at 17:00
  • @harrymc: The question isn't a duplicate from the one you linked. The answer simply touches on a similar enough issue. I'm no SU.SE expert but going by SE standards this isn't a duplicate.
    – Flater
    Nov 19, 2019 at 22:55
  • If you insist. Which part of my linked answer helped in your case? I suppose the Preload registry key?
    – harrymc
    Nov 20, 2019 at 6:15

1 Answer 1

0

The link posted in a comment on the question led me to an acceptable (though not ideal) solution.

Method 2 : Preloaded

  1. Use regedit to navigate to HKEY_USERS\.DEFAULT\Keyboard Layout\Preload. You will find there the list of keyboards that are preloaded at boot.
  2. Find the keyboard identifier among the list of Keyboard Identifiers
  3. Delete the key.

I had to perform this action for both HKEY_USERS\.DEFAULT and HKEY_CURRENT_USER.

After that, the two expected keyboard layouts (QWERTY/Belgian AZERTY) were being shown on startup.

There are a few side effects though:

  • The Belgian AZERTY language is set to NL instead of EN, which is not what I want.
  • I have not found a way to make the Belgian AZERTY the default instead of QWERTY.

But this at least solves the core issue at hand. If anyone finds a solution that doesn't have these side effects, I'll happily give them the answer tick.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.