I'm running an installer for a software on ubuntu 18.04 XFCE. When the installer finishes it must open a web browser for setup and comissioning and then finish the installation.

When it get's to that point it shows a popup error saying Failed to execute default web browser. input/output error.

I tried with Firefox and Chromium with same results, seems like the installer is trying to run the browser as root since the installer is running as the same user. And it looks like browsers can't run as root (?)(with sudo).

2 Answers 2


I ran into the same problem earlier. It was because I did not install any browsers.

To install Chrome:

  1. download it using this command: wget https://dl.google.com/linux/direct/google-chrome-stable_current_amd64.deb

  2. execute the downloaded installer: sudo apt install ./google-chrome-stable_current_amd64.deb

  3. launch the browser: google-chrome

Later, I decided to make the default browser icon to launch google chrome, so I followed Grant Curell's answer, basically:

  1. run xfce4-settings-manager
  2. find "Preferred Applications"
  3. under "Web Browser", click "Other..."
  4. type in /usr/bin/google-chrome


  1. In terminal run xfce4-settings-manager
  2. Preferred Applications
  3. In the web browser selection click other
  4. Type in /usr/bin/google-chrome --no-sandbox

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .