I was flashing the router with the Tomato firmware, but something went wrong; I'm not sure what. Now, the router responds to ping at (my Mac's on a static IP, but the web-interface doesn't come up.

I have read that this situation is recoverable in a [couple of places][2], but I haven't been having much success and so I wondered whether anyone could help.

From my Mac (OSX 10.5) I have tried to tftp a new vanilla-Linksys firmware to the router and reboot; according to the trace, this sends it but the router behaves no differently after a reboot.

I've read that if boot_wait is turned on, I'll have an easier time, but I haven't been able to find any instructions that tell me how I can tell whether I did this or not (I don't think I have, but I might have, when I tinkered the first time months ago - the router has worked since then, though).

I have found a couple of references to [something called JTAG][3], which seems like some kind of [homebrew diagnostic cable thing][4], but that's a little beyond my ken. Happy to try it, with muppet-level instructions, though (I do software, not hardware!).

So, I'm at a bit of a loss, really, and wondered whether anyone could provide me with the route (ha. ha.) out of this mess?

Hm, I can't post all the links I wanted to until I have some more reputation.


6 Answers 6


Have you tried failsafe mode. http://wiki.openwrt.org/oldwiki/openwrtdocs/hardware/linksys/wrt54gl

Check your arp cache. I found the openwrt pages useful for a similar problem.

Also note references to problems with the power supply. Everything seems ok but system doesn't come up. I swapped in an old power supply temporarily until I could order a new one.

  • Good point about the power supply - I've had an Asus WL500gP fail to boot, and it looked just like a bad flash. In the end, turned out that the wall wart couldn't give whole 2000 mA at boot (the power draw is considerably lower once the boot sequence finishes). Replacing it fixed the problem. Jan 17, 2012 at 13:14

If the router was interrupted during the flash, then you will more than likely have to telnet into the router and manually install the open source firmware.

  • How do I go about doing that? Jan 13, 2011 at 16:58
  • @PeterMounce This is done using the JTAG method and is different for each router. It is meant as a last resort deal. Jan 13, 2011 at 17:24
  • 1
    @KronoS: No, JTAG would be used if the router bootloader got corrupted. If you can telnet, the bootloader's ok, and JTAG isn't needed.
    – Ben Voigt
    Sep 5, 2011 at 16:00

You could try a hard reset. A good write up on dd-wrt is at Recover from a bad flash I used it when I fat-finger failed a Tomato firmware upgrade on my WRT54G V4. Reset everything and I was able to get to the web interface to restart things. /s/ BezantSoft

  • Tried that; no joy. Jan 13, 2011 at 16:57

I recently hard reset my router of the same model.

  1. unplug everything but the power
  2. use a paperclip to hold the reset button for 30 seconds
  3. while still holding the reset button, pull the power cord out
  4. hold the reset button another 10 seconds.
  5. plug it in and power it up.

this reset everything some nvram to factory for me but not others. So the router was now at but didn't DHCP for me. I had to assign my IP address to the correct range and then connect to the web interface.

  • This is the first solution I would recommend -- a "hard reset". If this doesn't work
    – Michael
    Jan 18, 2011 at 5:09

I would agree with Jay R. Wren. However, if a "hard reset" does not restore all defaults, I would download the default FLASH config, and flash the router again, in order to restore defaults.

Once you restore the router EPROM to it's factory defaults, you will be able to more forward from scratch, and get the results you want.


It could be only bad or broken PS, that is preventing Fw to load and causing blinking PS LED. I have replaced the PS and now is fine

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.