3

I have two screens and want to create a video of my work on Display 2.

OBS Properties for 'Display Capture'

So, added a source 'Display Capture'. What happens is in neither of the displays I'm able to see. Added anyways, clicked "Start Recording" but was getting black screen.

I tested also:

  • different sources, more precisely Window Capture (which doesn't suit my needs and sometimes works, sometimes doesn't and I didn't yet figure out why) and Game Capture (which never worked).
  • "Run as Administrator" and faced the same result.
  • Remove the HDMI cable and plug back in

Here is my last log file - https://obsproject.com/logs/gN1kPrBTngp0LIDH


Edit

Just gone through the following troubleshooting steps

Display Capture for NVIDIA-based Laptops

  1. Close OBS if it is currently open
  2. Go to the NVIDIA Control Panel by right clicking on your desktop, and then clicking on "NVIDIA Control Panel"
  3. Click on "Manage 3D Settings" if it is not already selected Under the Program Settings tab, click the "Add" button under where it says "Select a program to customize:"
  4. Navigate to the .exe path for OBS and add it to the list Default paths are: C:\Program Files\obs-studio\bin\64bit\obs64.exe and C:\Program Files (x86)\obs-studio\bin\32bit\obs32.exe)
  5. Make sure it is selected in the drop down list
  6. Then, under where it says "Select the preferred graphics processor for this program" open the drop down and select "Integrated graphics" from the list
  7. Save and apply, then open OBS and check Display Capture again

and still no success...

4
  • The log file seems alright with no major errors, did you try to tweak some settings?(encoder/hardware acceleration, etc).
    – CaldeiraG
    Nov 21, 2019 at 9:29
  • I also removed the HDMI cable, inserted back in and restarted the computer. Nov 21, 2019 at 9:33
  • When you added the Display Capture, did you resize it so it's just not a tiny pixel on the screen. Is it enabled/active? Are there any other things you're trying to display that it may be behind? Nov 21, 2019 at 11:38
  • Yes it's active. About the little red dot, I see it but once clicking it automatically disappears. Nov 21, 2019 at 12:06

2 Answers 2

3

TLDR; Settings > Graphics > Browse OBS > Options > Power Saving

  1. Go to your Windows Settings (gear icon in the start menu)

    Windows Settings

  2. Search for Graphics Settings

    graphics settings

  3. Select Desktop or Classic App

    graphics settings > desktop app

  4. Select Browse and find the obs64.exe path - which is typically located here:

    C:\Program Files\obs-studio\bin\64bit\obs64.exe
    

    obs64.exe

  5. Go to the Options

    OBS Options

  6. Set to Power Savings

    Options > Power Savings

2
  • 1
    The Display tab does not have a "graphics settings". Jul 5, 2020 at 20:36
  • 1
    @pacoverflow go to Windows settings and search for "Graphic" and see if it comes up. Worked for me in Windows 10.
    – Eoin
    Mar 31, 2021 at 20:27
1

The workaround I've used was to install the TinyTake app and was able to record the screen in a fast and easy way.

1
  • Doesn't really help with OBS though. I'm using it for the virtual web cam.
    – Eoin
    Mar 31, 2021 at 20:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.