2

I am using Ubuntu and Firefox 70.0.1 and at least 5-6 times a day the CPU goes to 100% because of Firefox. I tried about:performance but when the CPU goes 100%, that screen is blank. I tried restarting it with no plugins (I had only 2 plugins which I uninstalled, just to be sure) and nothing changed. I managed to do a htop screenshot. Is there a way to fix this problem?

htop Screenshot

LE: it seems that it's a fontconfig bug, more details here: https://askubuntu.com/questions/1076412/firefox-freezing-with-100-cpu-usage-for-30-seconds-when-launching-chromium and https://bugzilla.mozilla.org/show_bug.cgi?id=1566053

5
  • 1
    Have you tried with a fresh profile and/or safe mode?
    – dirdi
    Nov 29 '19 at 13:34
  • I did not try with fresh profile, but in safe mode it happens, also.
    – Taw
    Nov 29 '19 at 14:41
  • 1
    Then please create a new, additional profile (run firefox -ProfileManager) and check if it happens with a fresh profile, too.
    – dirdi
    Nov 30 '19 at 13:52
  • After one day of usage with a new profile, it seems to work ok...thanks for the idea :)
    – Taw
    Dec 2 '19 at 14:19
  • I am glad to hear. I made my comment become an answer.
    – dirdi
    Dec 2 '19 at 15:29
2

This is probably cause by a messed up profile.

  • Press Ctrl + Shift + O, click on Import and Backup > Backup to save your bookmarks.
  • Run firefox -ProfileManager
  • Create a new profile and make it your default
  • Press Ctrl + Shift + O, click on Import and Backup > Restore > Choose File ... to import your bookmarks from your old profile.

Or use Firefox Sync to keep your bookmarks and passwords, but be aware that if you sync other, additional settings, your new profile may get messed up, too.

2
  • Thanks for the answer, it seemed to work all day but in the evening when I restarted Slack (very strange), the problem appeared again...is there any debug tool or something to check the cause? thanks
    – Taw
    Dec 2 '19 at 15:45
  • Thank you for the answer, unfortunately it has nothing to do with the profile, it's more complex than that.
    – Taw
    Dec 3 '19 at 9:59
0

The OP seems to be correct is stating that this problem is caused by a bug in the way that Firefox interacts with fontconfig. According to the linked bug thread, it may be possible to workaround the problem by updating fontconfig to 2.13 or higher if your distribution and permissions permit it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.