1

Background:

This problem happened 5 months before Windows 10 version 1909 was released. So upgrading to Windows 10 1909 wasn’t an option. It also would not have solved this issue.

The reason I identified this problem is due to the fact I had two identical instances of Windows 10, running two different builds, of Windows 10 version 1903. I noticed one install had the options, and the other did not.

I recently ran into an issue, with my legacy system, at the time I had the problem it was running a build released before May 29, 2019.

When attempting to update the legacy system I noticed the option to defer feature updates and quality updates was missing. I had manually performed the update to Windows 10 version 1903 using the upgrade assistance, in an attempt to solve a problem, I had with a .NET Framework application.

enter image description here

At the time I was running two Windows 10 installation on two different systems. One was a clean Windows 10 version 1903 installation while the other was Windows 10 version 1809 which I manually upgraded to Windows 10 version 1903 in order to solve the unrelated problem.

I knew something was wrong when the legacy system didn't display the deferment options yet the new system did.

enter image description here

Why are options to defer feature updates and quality updates missing from the Advanced Windows Update options? The system had previously been running 1809 with those options set to 60 and 30 days respectfully.

| improve this question | | | | |
  • This issue has actually already been solved, I solved it several weeks ago, but only recently decided to submit the question and answer. While you are welcome to submit other solutions to this problem, I probably already tried it, so you should verify the solution solves the problem I described before you submit it. – Ramhound Dec 1 '19 at 19:49
2

It appears that this issue stems from a possible known issue caused by DeferFeatureUpdatesPeriodInDays and DeferQualityUpdatesPeriodInDays keys within Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsUpdate\UX\Settings being set to something other than 0.

Since Microsoft has not confirmed this is an issue with Windows 10 version 1903, I can only go by the confirmed cases I have read about, it does not appear to be a widespread issue though.

Source: Windows 10, version 1903 and Windows Server, version 1903

Confirmed, tested in Windows 10 Pro (x86) build 18362.116.

If you set a non-zero number of days to defer features updates or quality updates then they disappear from the Advanced options.

It's not a 'timeframe', as such. The contents of these Windows Update settings pages are only refreshed when you check for updates, either the automatic check or manually. Set a number of days then check for updates will make the option(s) disappear straight away.

Using Regedit to set 'DeferFeaturesUpdatePeriodInDays' or 'DeferQualtyUpdatePeriodInDays' back to zero in the key HKLM\SOTWARE\Microsoft\WindowsUpdate\UX\Settings will make them visible again (after another 'check for updates').

KB4497935, the CU for 18362.145, does not fix this bug.

I was able to confirm this was the case by changing the value of DeferFeatureUpdatesPeriodInDays to 0 and performed a reboot and the option to defer feature updates returned. As you can see the option to defer quality updates is still missing.

enter image description here

Once I set both DeferFeatureUpdatesPeriodInDays and DeferQualityUpdatesPeriodInDays to 0 and performed a restart both options finally returned.

enter image description here

enter image description here

Sources:

| improve this answer | | | | |
0

You may be able to fix this issue (not very widespread in my own review and as noted above) with DISM.

Open cmd.exe with Run as Administrator. Run: dism.exe /online /cleanup-image /restorehealth Follow this with: SFC /SCANNOW

Allow both to finish, restart and test.

Also try updating to V1909 (now out in production)

| improve this answer | | | | |
  • Since it wasn’t clear I had already solved this answer, and planned on accepting my own answer, I have provided that additional clarification. Since I had originally made it clear this happened before May 29, would appreciate, the appropriate amount of cleanup on your part – Ramhound Dec 1 '19 at 20:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.