0

I want to running SDK. The docs like this :

  1. For Running SDK you can use (MobaXterm or Putty)
  2. Create an SSH Session with the following data:

    Address/Host : xxx.xxx.xxx.xxx

    Port : 2222

    Username : Secret

    Password : secret

So I try to access it use Putty like this :

enter image description here

Then I click open and input username and password, the result like this :

enter image description here

How can I solve this problem?

Update :

I try Secret@xxx.xxx.xxx.xxx too. But it does not works

I have tried more than 10 times and failed. I tried using MobaXterm and winscp and that also failed. I'm confused to solve this problem

7
  • @HazardousGlitch software development kit – positive thinking Dec 1 '19 at 12:34
  • No, sorry, I mean what SDK are you using? Where are you getting the login info from? – HazardousGlitch Dec 1 '19 at 12:36
  • @HazardousGlitch Seems it use java. This is used for chatbot. We get info login from the vendor. our vendors made it for us – positive thinking Dec 1 '19 at 12:38
  • I would contact the vendor to verify the info and have them try connecting. It's possible the info wasn't set up correctly. Generally we can't help with Access Denied other than telling you what I and Thomas said. – HazardousGlitch Dec 1 '19 at 12:45
  • @HazardousGlitch ok i will do that. previously I thought I made a mistake in the configuration – positive thinking Dec 1 '19 at 12:47
0

It depends if your can access the host without this SDK via putty?

If not check first this: PuTTY password access denied

If it is possible to access the host via putty, then you have only the problem to pass authorization?!

Best option would be to use a SSH Private Key (Use as example PuttyGen to create a key) and let pagent running on background with the unlocked private key. Then there is no password based logon needed.

This is a detailed instruction: https://www.howtoforge.com/ssh_key_based_logins_putty

If your really wont to pass the passwort, you need to call putty like this:

putty -load MySession -pw MYPASSWORD

or without a session (use the default session params):

putty -P 2222 user@host -pw MYPASSWORD
2
  • I do not know. I will try that later. I just followed their documentation – positive thinking Dec 1 '19 at 12:49
  • could you resolve the problem with those hints? – Thomas Dec 2 '19 at 19:42
-1

I too Had a same problem then i Found that i had not done the port forwading so that i can access it from the public network,so make sure your port is opened for the public access which ever port you are using for ssh.

3
  • The fact the original author got an 'access denied' is a clear indication the server he is connecting to actually responded and rejected the credentials. Implying that it isn't caused by blocked ports. – amo-ej1 Mar 25 at 7:01
  • You are more then welcome to try ssh on closed port and know the error buddy – Sam David Mar 25 at 7:13
  • I get an error message which clearly states 'connection refused'. – amo-ej1 Mar 25 at 7:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.